Problem creating anchor link in Reactive 
Question

Good night,

I'm having an issue while I'm trying to create an anchor link on my reactive application.

My anchor is fine: 

But when I create the link to reference the anchor it creates:


Anyone had this problem before? 

Is there any solution for the anchor link on reactive? 

How do you create the href? 


Thank you in advance :) 

mvp_badge
MVP

Hi José Veiga ,

Let me know how are you creating a anchor tag like you are using link or html content for create Acnhor.

If you are using  Link widget than it will show


also you can HTML content for that- like


Result is


Hope this will help you.

Regards

Rahul Sahu

Rahul Sahu wrote:

Hi José Veiga ,

Let me know how are you creating a anchor tag like you are using link or html content for create Acnhor.

If you are using  Link widget than it will show


also you can HTML content for that- like


Result is


Hope this will help you.

Regards

Rahul Sahu

 Hey Rahul,

Thanks for your help but I already tried that.
I'm doing it with an HTML element as you can see:


But the result is: 

 

The objective is to create an anchor to another place on the same screen. We have a document with a lot of sections and we want to navigate on those sections using anchor links.  


Thanks in advance


mvp_badge
MVP

Hi José Veiga

can you show what content of href mean

and when you click on this its work or not.


Regards

Rahul Sahu

Not sure if this is still relevant but I solved it this way.


Create a HTML element 


Create a LINK element where you want the user to go


LinkOnClick is empty, just needed to get rid of the error..


Works fine for me, however in Outsystems UI there is a client action called "ScrollToElement" which works great and you can use a regular link which allows you to execute a normal client actions with additional logic



Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.