41
Views
6
Comments
Solved
[CryptoAPI] Error Component AES_ReadKey
Question
Forge component by Ricardo Silva
34
Published on 03 Mar 2019

Hello,


I have a problem with the AES_ReadKey component when I try to encrypt the password.


This problem only happens in Production, Development and Quality, there are no errors.


There is a problem with SavedKey?


I have attached the service center error logs.


Any idea why this error happens?


Regards,

Jorge


VDAlog2.PNG

Rank: #55412
Solution

Hello,

Swatantra, Luis thank you for your help :)

I have fixed the error.

The error was in SavedKey, I have generated a new SavedKey using AES_NewKey and AES_SaveKey.

After that I passed the new SavedKey Input Parameter to AES_ReadKey.


Regards,

Jorge

Rank: #109

Are you using the same version the component on all the environments?

Rank: #55412

Hi Swatantra, 

Thank you for your reply.

I'm using the same version, 2.0.

cryptoAPIVersion.PNG

mvp_badge
MVP
Rank: #132

Hello Jorge,

The print of the error is showing the "Decrypt" action and not Encrypt.

Can you check if you are passing the corrects input data to the action?

BR,

Luis

Rank: #55412
Solution

Hello,

Swatantra, Luis thank you for your help :)

I have fixed the error.

The error was in SavedKey, I have generated a new SavedKey using AES_NewKey and AES_SaveKey.

After that I passed the new SavedKey Input Parameter to AES_ReadKey.


Regards,

Jorge

Rank: #109

Wonderful Jorge, good to hear that you resolved it. And thanks for providing the pointers for future readers.

Rank: #109

Wonderful Jorge, good to hear that you resolved it. And thanks for providing the pointers for future readers.