[MSWordUtils] Pagination removed for other pages after adding Header and Footer on first page

Forge Component
(3)
Published on 5 Jul by Stuart Harris
3 votes
Published on 5 Jul by Stuart Harris

Pagination is removing for other pages when I am replacing the Header and Footer using MSWord_InsertImageInHeader and MSWord_InsertImageInFooter on first page in the document.

I am replacing the bookmark(Add) in the attached template to add some data. After generating the file new pages are adding but with no pagination. I have set the page number start from too in word file settings then also it's not working. 

Please help!


Regards,

Pratima




Hi Pratima,

To confirm, when you insert an image n the header or footer in a document that has page numbers, the page numbers are removed.

It appears this is a bug in the underlying library.

Kind regards,

Stuart

Stuart Harris wrote:

Hi Pratima,

To confirm, when you insert an image n the header or footer in a document that has page numbers, the page numbers are removed.

It appears this is a bug in the underlying library.

Kind regards,

Stuart

 Hi Stuart,

Thanks for the reply.

Yes, the attached document which I am using has page numbers, you can check adding some content to the next pages and added header and footer too on first page manually, it's working. Attaching a sample too for your reference.

Only after generating the document and adding headers and footers on first page is removing the page numbers.


Regards,

Pratima