131
Views
12
Comments
[Google Maps Library] Zooming in and moving the position of Google Map results in gray areas
Question
Forge component by OutSystems R&D
26
Published on 26 Feb 2020

Hi,

I am having problems using the Google Maps Library plugin. When I zoom in or move position on the Google Map, this results in gray areas (see attachment). It looks like Google Maps can't reload parts of the map. Problems are present with MABS 6.1 and 6.2 (problems are not present when I generate the Mobile App on MABS 5.6)

What have I already tried:

  1. New mobile page made with only the Google Maps on it (problem still present with MABS 6.1 and 6.2)
  2. Check in Google Chrome (problems not present)
  3. Tried different MABS versions 5.6, 6.1 and 6.2 (5.6 has no problems, 6.1 and 6.2 do have problems)
  4. All relevant dependencies refreshed and updated if necessary


I appreciate all advice and solutions, thanks!


Platform Version 11.7.2 (Build 6043)

ServiceStudio Version 11.7.15 (Build 23465)

Google Maps Library Version 4.1.4 (O11)

MABS Version: 6.2


Regards,


Robin

Image4.jpeg

Rank: #874

Hello Robin, 


I am having the same issue. You found any solution?


Thank you so much!

Rank: #7301

Hello Camila,


Unfortunately, no solution has been found yet. Do you also have this problem with MABS 6.2 or another MABS version?

Rank: #874

Hello Robin, 


actually I didn't test changing the mabs version because for that I need to change the version of others plugins. 

But the version that I am using now it is 6.2.

You have this issue in all the devices? Because I am only having it in Ipad devices.


You had the opportunity to discussed this issue with Labs team?


Thanks for your help!

Staff
Rank: #52

Hi,

I have an app built with MABS 6.2 and I see the "gray areas" when I zoom in/out or move the map position, but they load quickly and I can see the complete map after some milliseconds.
In your case, the map does not reload again?

Regards,
Sofia Mourato

Rank: #874

Hello Sofia, 

you tested using an Ipad? With an Ipad, these grey areas take long to load, or not load at all. 

I can't share a video here, but I will send you using a private message.


Thank you!

Staff
Rank: #52

Yes Camila, I'm using an ipad to test.
Can you send the app or OML so I can test on my side?

Sofia

Rank: #874

Unfortunally I can't share oml or app, because of security issues. :(

Staff
Rank: #52

Ok no problem, could you try to isolate in a different app the use case where you're having issues?
Then you can first check if the issue still happens, and then if affirmative, send me that specific one with your test. :) 

Rank: #7301

Hello Camila,


I only have this problem on all the iOS devices. MABS is related to Apple Devices. In Google Chrome, for example, this problem does not occur. Unfortunately, I have no way to test this on an Android device. 


@Sofia have already placed the Google Maps without logic in an empty screen, but the problem persisted.


Staff
Rank: #52

Hi Camila and Robin,

In fact, I don't have that issue on my iPad with MABS 6.2.

I would recommend you isolate the map on an empty screen without any logic - just the map and the necessary things to show some markers and test zooming in/out to see if the error persists.

My guess is that probably there are logic processing in the middle that's delaying the map rendering. This could happen (for instance) if you are using local variables in the map that are changed on the screen when you zoom or change something, so on and so forth. 

Rank: #7301

Our Theme is based on OSUIMobileBase and not OutSystemsUI. In OutSystemsUI there is a bit of CSS that solves the problem for me by putting it in the page CSS where the Google Maps is used.


.main-content {

    -webkit-box-flex: 1;

    -ms-flex: 1;

    flex: 1;

    position: relative;

}


@ Camila Does that solve the problem for you too?

Rank: #874

Hello Robin, 

Yes! This solved my problem too!

Thank you so much!