Could not access resource. Make sure the referenced resource is not outdated.

I'm getting an error trying to access a resource and I'm not sure what the issue is.  I've added an xsl file as a resource and I'm accessing it in the OnAfterResponse of an external rest api call.  I've changed the deploy option from Do Nothing to Deploy To Target Directory with no luck.  I get a similar message in both instances.  When the option is set to deploy, I can access the file via the path with no issues, but trying to access it from OnAfterResponse does not work.  I've also tried to update the resource by clicking Change Resource but still the same result.


Interesting development.  The module I had everything in is a service module.  I moved my API logic and resource to a different module that has a front-end and everything works fine.  Then I tried to make a public resource in a reactive web module, and reference it from my service module but it wouldn't let me reference it saying that it could only be referenced from a reactive or mobile app.  I noticed that resources can't be made public in a service module. I also tried to reference the public resource from a library module as well, but no luck, same message about only being available for Reactive and Mobile apps.  Something about this seems not right to me.  I will contact OutSystems support.

Hi Greg,

I know this is old topic but currently I'm facing the same issue as my consume API and resource in a service module. Do you have any update for this issue, if so please share your solution.

Thanks in advanced,


Hi Greg,
I get the same issue above. I put the certificate file in Resource under the core service module. I make an API and then I use that file in my action as the same binary input parameter.

Please provide us some advice if you experienced on it. 


Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.