I can't pass a local variable value to a screen input variable

Helo every one, I have a problem, I am trying to pass a local variable value to a screen input variable, but when I pass the local variable, in the other screen i always get the default value of the local variable type, How can I pass  local variable value to a screen input variable?


Best regards

Rafael

Hi Rafael,

Can you send some image for us understand better what you need?

Regards


Hi Rafel,

Could you please give little bit more information related to your problem statement

1) Which type of application your are referring? Reactive, Mobile or Traditional

2) Any screen clips to showcase how you are passing the value to the other screen

3) Is it that your are using a screen Destination node in an action flow?

4) Is it a link via which you are navigating to the other screen?


Try this --> Set the Screen B input parameter  to mandatory and try to pass the local variable value from Screen A to Screen B as input parameter


Regards,

Benjith Sam

Hello Rafael,

As far as I understood your question, you want to pass a local variable from one screen to another screen as an input variable?

If so, you just need to create an input variable on the second screen. Right click on screen and:


Then when you navigate from screen 1 to screen 2, you just need to assign the local variable to the input parameter of the second screen.


Kind regards,

Rui Barradas

Rui Barradas wrote:

Hello Rafael,

As far as I understood your question, you want to pass a local variable from one screen to another screen as an input variable?

If so, you just need to create an input variable on the second screen. Right click on screen and:


Then when you navigate from screen 1 to screen 2, you just need to assign the local variable to the input parameter of the second screen.


Kind regards,

Rui Barradas

 

 Hello Rui, thanks for your answer, that is exactly what I want, and that is exactly what I did, but in my screen 2 I always get the default value of my local variable type, in this case is a Decimal variabe.

Here i my local variable from my First screen

And here in the button Pegar, I pass the local variable Value to my second screen 

But always in the second screen I recive a 0 value (default value for decimal type),

Aditionally, I hace a screen action, where I assign the value of my local variable (even I tried with a hardcore value) 

This screen action runs before I click the button "Pegar" which is the button that sends the local variable value to the second screen

Rafael,

Look if the type is the same in both screens (decimal).

Regards.

Hello Rafael,

Can you execute a debug on the CheckBoxOnChange action in order to validade that the value of the variable is beeing assigned properly before you navigate to the second screen?

Back to the second screen, please make sure that the input type is also a decimal :)


Let me know if it worked for you.


If not, please share the OML file so I can take a look.


Kind regards,

Rui Barradas

Solution

Rui Barradas wrote:

Hello Rafael,

Can you execute a debug on the CheckBoxOnChange action in order to validade that the value of the variable is beeing assigned properly before you navigate to the second screen?

Back to the second screen, please make sure that the input type is also a decimal :)


Let me know if it worked for you.


If not, please share the OML file so I can take a look.


Kind regards,

Rui Barradas

 

 Hello, I finally notice tha my proble was that I needed to refresh my table after assignind the value, so now My variable arrives fine to my second screen 


Thanks every one

Solution

Glad that we could help.

Let us know if you have any further questions.


Kind regards,

Rui Barradas