Integration Studio - some attributes were ignored
Question

I am trying to create an Entity in Integration Studio by connecting to a view in a database. The view has 4 columns. One of the columns has hours in form of a decimal with 2 positions after the decimal. For example 674.30. When I try to generate the entity, I get a message "Some attributes were ignored." The details say:

Original Type: HOURS

Data Type: No Type (automatically ignored)


How can this be resolved? 

Thanks for your response Jose. The datatype in the DB was HOURS(money). I ended up converting it in the view to varchar(10) which fixed the issue. The entity was created successfully.  

That's great to hear!

Michael Furnari wrote:

Thanks for your response Jose. The datatype in the DB was HOURS(money). I ended up converting it in the view to varchar(10) which fixed the issue. The entity was created successfully.  

 

 

Please validate that the Data Type of the column directly from the DB is compatible to OS Data Types.

Some data types cannot be converted automatically so please check that.

If you are able to provide screenshots, that can help you and I analyze further.

Thanks for your response Jose. The datatype in the DB was HOURS(money). I ended up converting it in the view to varchar(10) which fixed the issue. The entity was created successfully.  

That's great to hear!

Michael Furnari wrote:

Thanks for your response Jose. The datatype in the DB was HOURS(money). I ended up converting it in the view to varchar(10) which fixed the issue. The entity was created successfully.  

 

 

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.