Hey guys,

I am using OS11 to create a simple test screen to see if an action is still cached should an exception be raised.

Problem is I can't even simulate the cache situation both in my personal environment nor at the client I am working at which is on-premises. How I tested this is by placing a break point in the cached action and then sent the same input parameter to see if it would be called or ignored since it was already cached. In my case it always hit the breakpoint as depicted below, what am I doing wrong?

I also attached the OML.

Thanks in advance.



Hi Ricardo,

I only have a personal environment, so I can't test caching, but one thing that comes to mind is that maybe the act of debugging itself overrides the caching.  At least, that would make sense to me, when I'm debugging I want to see everything that happens, including the stuff that would normally be skipped due to caching.

Dorine

Dorine Boudry wrote:

Hi Ricardo,

I only have a personal environment, so I can't test caching, but one thing that comes to mind is that maybe the act of debugging itself overrides the caching.  At least, that would make sense to me, when I'm debugging I want to see everything that happens, including the stuff that would normally be skipped due to caching.

Dorine

Thanks for the suggestion Dorine. I don't think it's that because I remember that before when an action is cached even in dubug mode it would be skipped. Unless of course things have changed from version 11. I'll keep on trying to figure out why or hopefully someone else can give me more suggestions :)