the insure connection alert appears whenever the environments is connected

Hello

What is the problem of getting the message as shown below?

Where we can fix that?

It always appear whenever the environment is being  started.

Best regards

EiMon


Hello EiMon WA,

That message means Service Studio is not able to connect to the Environment using HTTPS. Usually it's a warning that there's something wrong, either with the configurations of the Environment or the Network/Firewall not allowing access.

If you carry on with the connection (and succeed) you are sending your developer credentials and all data on following operations in the clear (can be intercepted and tampered with by malicious attackers)

Hope this helps!

This is mostly due to expired certificate or no certificate available for the env url. One thing that helped me mitigate this in past was to access your dev URl through IE or the default browser. It will try to add the certificate on your machine. Restart the service studio. It didn't give me the error post that. Give it a try!


Cheers,

tushar 

Hi EiMon,

I've faced this issue a few months ago as well. 

In my case the connection was marked as using SSL , but service studio didn't use SSL. 

I had to change a settings-file (I thought there were more options to solve it). I don't know the right location anymore, but if you search in your OutSystems / Service Studio folder (or in the AppData folder) for files containing your environmenturl, than you will find an xml, which contains a property like 'IsSSL'. 

That property has to be True. (Be sure that you closed Service Studio )

Regards, Hans