Platform Server 5.1 New install... stalled at SCInstall.bat

Platform Server 5.1 New install... stalled at SCInstall.bat

  

Can anyone help me solve this problem...

I want to set up a 5.1 dev platform...but am running into some problems:

I can see that it has occurred before under older environments - but none of the suggestions to fix it are working for me.

http://www.outsystems.com/NetworkForums/ViewTopic.aspx?Topic=SCInstall.bat-fails


This is a brand new installation on a New Server with the following s/w:

W2008R2/64bit
SQLSVR2008/64bit - SP1
.NET (x64) v2.0.50727, v3.0, v3.5, v4.0 installed
.NET (x64) 2.0 SDK
IIS7

I have been following the Installation checklist and it was all going fine until this point (cmd line as Domain Admin!) :

C:\Program Files\OutSystems\Platform Server>SCInstall.bat
Service Center Installer v5.1.0.10

Start installing Service Center v5.1.0.10...

Publishing Extension(s)...
Publishing Extension 'OMLProcessor'...
Publishing Extension 'IntegrationStudio'...
Reading ServiceCenter.oml oml file information...
Adding ServiceCenter eSpace to database...
Compiling ServiceCenter eSpace...
Preparing ServiceCenter eSpace deployment...
Deploying ServiceCenter eSpace...
Creating ServiceCenter default tenant...
Preparing database...
Initializing Service Center...
ServiceCenter initialization failed. Failed to get HttpResponse from http://127.0.0.1/ServiceCenter/DoBootstrap.aspx

When I try and serve a plain HTML page from
http://127.0.0.1/ServiceCenter/plain.htm - it works

When I try and serve a 'plain' aspx (no code just html inside)
http://127.0.0.1/ServiceCenter/plain.aspx - it works

When I try any other doc (from outsystems) under this path then I WAS getting 403 - denied.

Then I noticed that the Application Pool for OutsystemsApplications is set to Enable32BitApplications=False.  I tried flipping this to 'True' and now I get:
 

Server Error in '/ServiceCenter' Application.


Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Object reference not set to an instance of an object.

Source Error:


 

				Line 20:     <sessionState cookieless="false" regenerateExpiredSessionId="true"  mode="Custom" customProvider="OutSystemsSessionProvider">
Line 21:       <providers>
Line 22:         <add name="OutSystemsSessionProvider" type="OutSystems.HubEdition.RuntimePlatform.SessionState.SqlSessionStateStore" />
Line 23:       </providers>
Line 24:     </sessionState>

Source File: C:\Program Files\OutSystems\Platform Server\running\ServiceCenter.01061161540\web.config    Line: 22


Version Information: Microsoft .NET Framework Version:2.0.50727.4200; ASP.NET Version:2.0.50727.4205 



Note - I might have been wrong to allow the 32bit Apps - but this sort of thing is a common problem on x64!


All the Outsystems services are up and working - I even tried removing the repository and re-running all the configuration tool settings again - but that doesn't seem to be the problem.

I have checked that 'NetworkService' has got read/execute rights on the PlaformServer/running/ServiceCenter....  directory.


Here is a similar stack trace from Windows Events:
Event code: 3008
Event message: A configuration error has occurred.
Event time: 08/07/2010 15:31:06
Event time (UTC): 08/07/2010 14:31:06
Event ID: 2d119e3f66fe40f6ba3f9261607d64c0
Event sequence: 10
Event occurrence: 9
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/1/ROOT/ServiceCenter-1-129230726804313886
    Trust level: Full
    Application Virtual Path: /ServiceCenter
    Application Path: C:\Program Files\OutSystems\Platform Server\running\ServiceCenter.01061161540\
    Machine name: JMR0010
 
Process information:
    Process ID: 2552
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE
 
Exception information:
    Exception type: ConfigurationErrorsException
    Exception message: Object reference not set to an instance of an object. (C:\Program Files\OutSystems\Platform Server\running\ServiceCenter.01061161540\web.config line 22)
 
Request information:
    Request URL: http://localhost/ServiceCenter/_TimerHandler.asmx
    Request path: /ServiceCenter/_TimerHandler.asmx
    User host address: ::1
    User: 
    Is authenticated: False
    Authentication Type: 
    Thread account name: NT AUTHORITY\NETWORK SERVICE
 
Thread information:
    Thread ID: 7
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace:    at System.Web.Configuration.ProvidersHelper.InstantiateProvider(ProviderSettings providerSettings, Type providerType)
   at System.Web.SessionState.SessionStateModule.InitCustomStore(SessionStateSection config)
   at System.Web.SessionState.SessionStateModule.InitModuleFromConfig(HttpApplication app, SessionStateSection config)
   at System.Web.SessionState.SessionStateModule.Init(HttpApplication app)
   at System.Web.HttpApplication.InitModulesCommon()
   at System.Web.HttpApplication.InitModules()
   at System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers)
   at System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context)
   at System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context)
   at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
 


I am itching for Intelliwarp coding!!

Rgds,
Paul.

 

Hi Paul,

i would suggest you send that information to support@outsystems.com

Thanks,

RNA
Hi Paul

The problem is that you've flipped the application pool architecture to 32 bits, which also requires to have the OutSystems key app settings on the machine.config file for the 32 bits architecture, since the Agile Platform only changes the 64 bits version of the machine.config file.

For setting up a Windows 2008 R2 to run the worker processes in 32 bits, please follow the instructions at Running eSpaces in 32-bit mode in Windows 2008 R2.

Cheers

Miguel Simões João
Miguel,

Thanks for the reply - but this was actually an act of desparation - I didn't want to run it 32bit and from the link you give me this has convinced me this is something I don't want to do.  So I am still left with the problem that when I put this setting back to normal (64bit) I still get a 403 access denied.   I have tried to override the application pool authority to a 'root' type user  and it still does not work.

I am re-building the W2008 server from OS Roles up.  If it still doesn't work then I will be back later.
Hi Paul

If you want 64 bits, just revert the changes done to the app pools, and let's troubleshoot the 403 error.

Resume the installation of the Agile Platform, up to the scinstall.bat, following the installation checklist document.

Then, run the scinstall.bat command, and if it fails, open a web browser and access the URL: http://127.0.0.1/ServiceCenter/DoBootstrap.aspx.

Send us the content of the resulting page, which will help us troubleshooting the error.

Thanks

Cheers

Miguel Simões João

Miguel,

Right I stripped the Application Server Role and IIS from the machine, rebooted and started everything again.


I still get the failure right at the end of SCInstall.bat (ServiceCenter initialization failed. Failed to get HttpResponse from
http://127.0.0.1/ServiceCenter/DoBootstrap.aspx)

The error message when I try this in IE browser is simply: "You are not authorized to view this page"
I also get this when I try any other page.

Here is the origin from the failed request log:

-MODULE_SET_RESPONSE_ERROR_STATUS

ModuleName

IsapiModule

Notification

128

HttpStatus

403

HttpReason

Access Denied

HttpSubStatus

0

ErrorCode

0

ConfigExceptionInfo

Notification

EXECUTE_REQUEST_HANDLER

ErrorCode

The operation completed successfully. (0x0)


So I look at the ordered handler list for .aspx and it is: 'PageHandlerFactory-ISAPI-2.0-64' (right I think).

So I check the /ServiceCenter application properties in IIS mgr:
ApplicationPool is OutsystemsApplications Anonymous Authentication enabled (pass thru)
Windows Authentication enabled.
Physical Path: C:\Program Files\OutSystems\Platform Server\running\ServiceCenter.2088255232

So I go to the Application pool:

OutsystemsApplications / .NET 2.0.50727 / Classic / Start immediately
Advanced:
Enable 32bit Apps - false
Identity 'Network Service'

From previous posts I understand that the identity Network Service = {Domain}/{NameOfMachine}$

If so, I have checked its 'effective permissions' on this directory and it has everything except (fullcontrol, delete, take ownership).

I have checked the event log and the Outsystems services are started ok without errors.
Only Warning in the event log today is :

IIS-W3SVC-WP: The directory specified for caching compressed content C:\inetpub\temp\IIS Temporary Compressed Files\OutSystemsApplications is invalid. Static compression is being disabled.

 The only service that is stopped that might be a problem is 'ASP.NET State Service' (manual start up) but I started this up and it made no difference.

Any suggestions??

PS - UAC is on on this server - but I am doing everything as 
 {Domain}/{Administrator} (i.e. God)

Attached is c:\windows\Microsft.Net\Framework64\v2.0.50727\CONFIG\machine.config


 

Hi Paul

If you get just a plain text message saying "You're not authorized to view this page.", and the source code of that page is also just that plain text message, you could be hitting on the internal network problem.

Run the OutSystems Configuration Tool as administrator, and check the Internal Network IP Addresses field in the Network tab. If it's not empty, then you'll need to also add the 127.0.0.1 IP address, otherwise, the bootstrap will fail. If it's empty, then this is not the problem.

When there are a list of IP addresses and IP address ranges set in this field, the Agile Platform only allows access to "internal only" applications to computer with those IP addresses or from those ranges. Having that field blank, will not force any restriction, allowing requests from any IP address to be served by the applications.

Also, the warning regarding the IIS compression, suggests that you're either missing some folders on the C:\inetpub, or have a misconfigured IIS compression. Create the missing folders.

Let us know your findings.

Cheers

Miguel Simões João

Miguel,

**Some** but not full success... answers in line below:

Run the OutSystems Configuration Tool as administrator, and check the Internal Network IP Addresses field in the Network tab. If it's not empty, then you'll need to also add the 127.0.0.1 IP address, otherwise, the bootstrap will fail. If it's empty, then this is not the problem.

>> It was set to 127.0.0.1; 192.168 - but I blanked it anyway - this made no difference.

Also, the warning regarding the IIS compression, suggests that you're either missing some folders on the C:\inetpub, or have a misconfigured IIS compression. Create the missing folders.

>> I created the directory and gave {Domain}/{MachineName}$ full acesss - the error is now gone, but the Access denied problem was still there.


>> I then tried three things - and they got the bootstrap to APPEAR to work:

a. I logged into SQL Svr Manager console and increased the SQL access rights of hubruntime, hublog and hubstate etc to the equivalent of 'full control' on outsystems catalog db and the ASPState db respectively.  This may or may not have made a difference because at the same time....

b. I noticed that my Windows Update to install SQLSvr 2008 SP1 had failed a few days ago - so I reapplied this and rebooted the server (again)

c. Then I ran the SCInstall.bat again and it went through without an error.

I now get the ServiceCenter login page - BUT the default admin login does not work - I get Invalid Login or Password.

I have delved into the outsystems catalog db and there is a row in ossys_Espace for Service Center and it is active.  However, there is no rows in ossys_User - which is what I thought the bootstrap would have done.

Is there any way to debug what is happening to the login?   There is nothing but a 1k .cache file in C:\Program Files\Outsystems\Platform Server\Logs

Rgds,
Paul.


 

Hello Paul

Regarding the internal network configuration, that fact the the 403 disappear after the reboot, lead me to suspect that you're missing the IIS reset after changing the Internal Network ...

The fact that you've change the privileges of the database users on the OutSystems catalog, should not impact the IIS 403 access error, since if the users didn't had enough privileges, you'd be getting a different error.

Nevertheless, for the problem at hand, it seems that the bootstrap failed to create the admin user, so proceed as following:
  1. Make sure you have the outSystems Service up and running
  2. Execute the scinstall.bat command again and confirm success.

Cheers

Miguel Simões João
Miguel,

I have done this twice - and both times the same  - no error but no row in ossys_user and no way to log in.

I have inspected ossys_log_error_0 and the only row is a warning that it is returning 'Development mode' because the value in the DB is null - because this hasn't been set yet because I can't log in to do it.

What next?

Rgds,
Paul.





I hate threads the exactly match your situation and then stop at the above point [before the problem is solved] - so I want to add this note to say how the problem was solved (even if it doesn't definitively identify why)...

A big THANK YOU to support@outsystems.com  who did the following....

Removed my outsystems catalog (renamed)

Created a new catalog ***crucially*** altering the Collation in the SQL Svr Manager  Create Database dialog from '<default>' to 'Latin.....CI_AI' (case insensitive,accent insensitive).

The default install for SQLSvr 2008 is CI_AS (Accent Sensitive)  - So I had unwittingly deviated from the Install script which was probably the problem.

Note that if you need the server defaults (for other reasons) to not be CI_AI for all databases created, then you'll need to manually alter it for outsystems as above.

Re-running SCInstall.bat and it all works fine now.

Hi Paul,

Thanks for your last post.
This worked for me except running the SCInstall.bat

I kept getting:
C:\Program Files\OutSystems\Platform Server>SCInstall.bat
Service Center Installer v5.1.0.14
 
Start installing Service Center v5.1.0.14...
 
Publishing Extension(s)...
Publishing Extension 'OMLProcessor'...
Publishing Extension 'IntegrationStudio'...
Reading ServiceCenter.oml oml file information...
Adding ServiceCenter eSpace to database...
Compiling ServiceCenter eSpace...
Preparing ServiceCenter eSpace deployment...
Deploying ServiceCenter eSpace...
Creating ServiceCenter default tenant...
Preparing database...
Initializing Service Center...
ServiceCenter initialization failed. Failed to get HttpResponse from http://127.0.0.1/ServiceCenter/DoBootstrap.aspx
 
C:\Program Files\OutSystems\Platform Server>

The default admin/admin login failed.
After that, I manually ran the bootstrap through opening http://127.0.0.1/ServiceCenter/DoBootstrap.aspx in I.E.
Now I seem to be able to execute service center with the default login.

P.S.: This issues came with the 5.1.0.14 platform.

Cheers,

Eric
C:\Program Files\OutSystems\Platform Server>SCInstall.bat
Service Center Installer v5.1.0.14
 
Start installing Service Center v5.1.0.14...
 
Publishing Extension(s)...
Publishing Extension 'OMLProcessor'...
After that
Publishing Extension 'IntegrationStudio'...
Reading ServiceCenter.oml oml file information...
Adding ServiceCenter eSpace to database...
Compiling ServiceCenter eSpace...
Preparing ServiceCenter eSpace deployment...
Deploying ServiceCenter eSpace...
Creating ServiceCenter default tenant...
Preparing database...
Initializing Service Center...
ServiceCenter initialization failed. Failed to get HttpResponse from http://127.
0.0.1/ServiceCenter/DoBootstrap.aspx
 
C:\Program Files\OutSystems\Platform Server>C:\Program Files\OutSystems\Platform Server>SCInstall.bat
Service Center Installer v5.1.0.14
 
Start installing Service Center v5.1.0.14...
 
Publishing Extension(s)...
Publishing Extension 'OMLProcessor'...
Publishing Extension 'IntegrationStudio'...
Reading ServiceCenter.oml oml file information...
Adding ServiceCenter eSpace to database...
Compiling ServiceCenter eSpace...
Preparing ServiceCenter eSpace deployment...
Deploying ServiceCenter eSpace...
Creating ServiceCenter default tenant...
Preparing database...
Initializing Service Center...
ServiceCenter initialization failed. Failed to get HttpResponse from http://127.
0.0.1/ServiceCenter/DoBootstrap.aspx
 
C:\Program Files\OutSystems\Platform Server>

I have the same problem with 5.0 installation now. with slightly altered stuff.

- check the machine.config.
My guts are telling me, that sometimes OS is screwing up the machine.config with strange (guessing utf-16) characters.
That means machine.config is corrupt.


Hi all

If the scinstall.bat command is failing with the message ServiceCenter initialization failed. Failed to get HttpResponse from http://127.0.0.1/ServiceCenter/DoBootstrap.aspx then you need to check with error exactly is the IIS returning.

For, access the URL http://127.0.0.1/ServiceCenter/DoBootstrap.aspx with the web browser local to the server it self. The IIS error should have an HTTP code and a substatus code, like 403.19. Depending on the HTTP and substatus codes, the root cause of the problem may vary.

If in fact its due to corrupted machine.config, then you should get a HTTP 500 error, with information that the configuration file gave an error while parsing.

Eitherway, please check theHTTP and substatus code before jumping into conclusions. If you need help in determining possible causes for the IIS error, just post here a screen shoot of the web browser output.

Cheers

MIguel Simões João
Guys,

I think I have found a consistent way to make the SCInstall.bat work:

At the point in the install when you normally run SCInstall.bat from the installation notes I always:

1. Reboot the server just before this step (if this is possible)
2. Run SCInstall.bat from a CMD (Command prompt) that I have explicitly 'Run As Administrator' - even if I am logged in as an Administrator!

I've now done several installs and not had these problems if I do the above.

Hope this helps.
Paul.