Error while deploying To UAT

Hi all,

Can someone help on below deployment problem please ..Did multiple try but getting these below issues always...


Security


Error detail


Back to Log


Id


658dc5ee-c8b6-4c8f-8ad4-b4fb16461284


Time of Log


2020-08-15 09:09:16


Request Key


Module


Tenant


User


Session Id


Server

Xyz


Source


Deploy


Message


Error finalizing deploy of eSpace 'BI_Annuity' with unique identifier  (Deployment failed: Ping validation failed. Deployed module version does not match the version that was compiled. Status: OK. Content: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >

<html>

<head>

<title>ping</title>

<script type="text/javascript" src="/BI_Annuity/ruxitagentjs_ICA27SVfghjqruvx_10197200717183318.js" data-dtconfig="rid=RID_-741847717:Deployment failed: Ping validation failed. Deployed module version does not match the version that was compiled. Status: OK. Content: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >

<html>

<head>

<title>ping</title>

<script type="text/javascript" src="/BI_Annuity/ruxitagentjs_ICA27SVfghjqruvx_10197200717183318.js" data-dtconfig="rid=RID_-741847717 (Espace name: BI_Annuity, Test area name: , Is running operation: False, Unique ID: , Deploy to separate folder: True, Not using differential Deploy, Previous deployment information wasn't found, Virtual Directory was reused)) in xyz


Thanks,

Dileep

Dileep Verma wrote:

Hi all,

Can someone help on below deployment problem please ..Did multiple try but getting these below issues always...


Security


Error detail


Back to Log


Id


658dc5ee-c8b6-4c8f-8ad4-b4fb16461284


Time of Log


2020-08-15 09:09:16


Request Key


Module


Tenant


User


Session Id


Server

Xyz


Source


Deploy


Message


Error finalizing deploy of eSpace 'BI_Annuity' with unique identifier  (Deployment failed: Ping validation failed. Deployed module version does not match the version that was compiled. Status: OK. Content: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >

<html>

<head>

<title>ping</title>

<script type="text/javascript" src="/BI_Annuity/ruxitagentjs_ICA27SVfghjqruvx_10197200717183318.js" data-dtconfig="rid=RID_-741847717:Deployment failed: Ping validation failed. Deployed module version does not match the version that was compiled. Status: OK. Content: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >

<html>

<head>

<title>ping</title>


<script type="text/javascript" src="/BI_Annuity/ruxitagentjs_ICA27SVfghjqruvx_10197200717183318.js" data-dtconfig="rid=RID_-741847717 (Espace name: BI_Annuity, Test area name: , Is running operation: False, Unique ID: , Deploy to separate folder: True, Not using differential Deploy, Previous deployment information wasn't found, Virtual Directory was reused)) in xyz


Thanks,

Dileep




 can u check below post:

https://www.outsystems.com/forums/discussion/47523/server-installation-issue-on-premises/#Post174155 


 

 

Vijay Malviya wrote:

Dileep Verma wrote:

Hi all,

Can someone help on below deployment problem please ..Did multiple try but getting these below issues always...


Security


Error detail


Back to Log


Id


658dc5ee-c8b6-4c8f-8ad4-b4fb16461284


Time of Log


2020-08-15 09:09:16


Request Key


Module


Tenant


User


Session Id


Server

Xyz


Source


Deploy


Message


Error finalizing deploy of eSpace 'BI_Annuity' with unique identifier  (Deployment failed: Ping validation failed. Deployed module version does not match the version that was compiled. Status: OK. Content: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >

<html>

<head>

<title>ping</title>

<script type="text/javascript" src="/BI_Annuity/ruxitagentjs_ICA27SVfghjqruvx_10197200717183318.js" data-dtconfig="rid=RID_-741847717:Deployment failed: Ping validation failed. Deployed module version does not match the version that was compiled. Status: OK. Content: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >

<html>

<head>

<title>ping</title>


<script type="text/javascript" src="/BI_Annuity/ruxitagentjs_ICA27SVfghjqruvx_10197200717183318.js" data-dtconfig="rid=RID_-741847717 (Espace name: BI_Annuity, Test area name: , Is running operation: False, Unique ID: , Deploy to separate folder: True, Not using differential Deploy, Previous deployment information wasn't found, Virtual Directory was reused)) in xyz


Thanks,

Dileep




 can u check below post:

https://www.outsystems.com/forums/discussion/47523/server-installation-issue-on-premises/#Post174155 


 

 

 Hi Vijay, thanks for the reply. But our problem is not related to underline connections problem.as it's states the problem is something else. As we can see all server and services are up and running but still it's showing deployment controller is down. Please find the screen shot attached..What may be the reasons that it's showing down as we have checked all deployment services is running up and fine


 

Dileep Verma wrote:

Vijay Malviya wrote:

Dileep Verma wrote:

Hi all,

Can someone help on below deployment problem please ..Did multiple try but getting these below issues always...


Security


Error detail


Back to Log


Id


658dc5ee-c8b6-4c8f-8ad4-b4fb16461284


Time of Log


2020-08-15 09:09:16


Request Key


Module


Tenant


User


Session Id


Server

Xyz


Source


Deploy


Message


Error finalizing deploy of eSpace 'BI_Annuity' with unique identifier  (Deployment failed: Ping validation failed. Deployed module version does not match the version that was compiled. Status: OK. Content: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >

<html>

<head>

<title>ping</title>

<script type="text/javascript" src="/BI_Annuity/ruxitagentjs_ICA27SVfghjqruvx_10197200717183318.js" data-dtconfig="rid=RID_-741847717:Deployment failed: Ping validation failed. Deployed module version does not match the version that was compiled. Status: OK. Content: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >

<html>

<head>

<title>ping</title>


<script type="text/javascript" src="/BI_Annuity/ruxitagentjs_ICA27SVfghjqruvx_10197200717183318.js" data-dtconfig="rid=RID_-741847717 (Espace name: BI_Annuity, Test area name: , Is running operation: False, Unique ID: , Deploy to separate folder: True, Not using differential Deploy, Previous deployment information wasn't found, Virtual Directory was reused)) in xyz


Thanks,

Dileep




 can u check below post:

https://www.outsystems.com/forums/discussion/47523/server-installation-issue-on-premises/#Post174155 


 

 

 Hi Vijay, thanks for the reply. But our problem is not related to underline connections problem.as it's states the problem is something else. As we can see all server and services are up and running but still it's showing deployment controller is down. Please find the screen shot attached..What may be the reasons that it's showing down as we have checked all deployment services is running up and fine


 

 

 Hi Dileep,

The first try it is restart the outsystems services and see if the error is still persisted.

If still doesn't work, open a support ticket.