Built in validation is not working

Hi

i am developing reactive Web application.i have one form and against next button "builtinvalidation" is true.but when i am trying to open the page then before clicking the Next button all validation message are fired.i have one form and under this form i have added all fields.please find the screenshot.validation message should fire after clicking the next button but it is coming before clicking the button

 

Hi,


Are you using "NextOnClick" in any "OnAfterFetch" from that screen?


Hope this can help.


Best regards,

Ricardo M Pereira

Ricardo Pereira wrote:i am calling next on click only on against button.but if i mentioned Buitinvalidation =false then also validation message is coming

Hi,


Are you using "NextOnClick" in any "OnAfterFetch" from that screen?


Hope this can help.


Best regards,

Ricardo M Pereira

 

 

Are you updating some fields are the page has loaded (Perhaps in the OnRender event)? I have lots of forms in Reactive and I don't have this issue at all although I do recognize this behavior when I transition away from a form that has not yet been completed. Never really understood why that is happening, perhaps it's related.

Vincent Koning wrote:hi

i am not able to track.i dont have any onrender and onintialize event for that page but still it is coming


Are you updating some fields are the page has loaded (Perhaps in the OnRender event)? I have lots of forms in Reactive and I don't have this issue at all although I do recognize this behavior when I transition away from a form that has not yet been completed. Never really understood why that is happening, perhaps it's related.