Application not showing in Lifetime

Hello all,

We have a cloud environment: Lifetime + Dev + Prd

I've created a solution that contains an application and all it's dependencies (this solution was created on a on premises server). 

I've uploaded the solution to our Cloud Dev server, and published it (IPP step, successful).

The next step is to deploy that application in our Cloud Prd Server, this is were i´m having problems...I´m using lifetime do Prd deployment, but the application doesn't appear in the applications list to deploy to PRD.

Is it something related to this: https://www.outsystems.com/forums/discussion/60472/not-visible-in-lifetime/ ??

Thank you in advance.


Hi,

I Don't know what goes wrong on your side, but it does not look to be the issue described in the link you share.

Regards,. Daniel

Check to see if for some reason it thinks there isn't a difference between the two environments, by default only apps that have a difference are listed but you can change this to show all apps.

The other thing to try is in the main Applications page search for the app and check the versions in each environment


If that fails your environment data may be out of sync, try forcing a manual sync like so


Also go into service centre and Factory on dev environment and make certain that the application is listed in there.

Hi all,

I've tried all the sugestions but the application is still not showing. 

This is a screenshot of our Cloud DEV Server, the application is installed and published.


This is a screenshot of Lifetime Server, the application doesn't exist:


Hi,

Am I observing correctly that your LifeTime application is installed on the same Cloud Dev server?

I'm asking since that is not a supported scenario anymore in OutSystems 11. 

If this is not the case, can you make sure your DEV and PRD environments are correctly registered in LifeTime?

Regards,

Nordin

@Nordin, LifeTime can still be in DEV environment (our partner env is). I believe it is still valid if your platform migrated from V10 to V11 or for partner environments. 

I think this may be a case of having to raise a support ticket

Just double check that you didn't actually upload the application into the lifetime service center, yes lifetime is actually a full environment of its own that you can upload solutions to but doesn't show under lifetimes deployment environment 

@Daniel, now I'm thinking installing LifeTime on an existing environment might still be supported for Cloud, but not for On-Premises infrastructures.

Anyways, I do not think that is the issue here. There are two things you need to make sure of.

  • Make sure the Cloud DEV and PRD environments are correctly registered in your LifeTime application
  • Make sure the Processes run by the LifeTimeEngine module are running smoothly without errors.

Hope this helps.

Regards,

Nordin

Hi all,

After analysing all of the platform, I can't seem to find anything that it's strange. Everything seems to be ok, except for that specific application, through the day, I've been uploading new solutions, publishing them and eventually deploying them to PRD with no issues. 

Probably, like Jeanene Williams said, i´ll need to raise a ticket.