21
Views
1
Comments
[Microsoft Login Connector Reactive] Not retrieving roles
Question
Forge component by Miguel Amado
3
Published on 27 Nov 2020

Hi,

I try to retrieve the role of a specific user aswell but the role remains empty in the request.

Let me specify it: 

  • Created a role in Azure AD called: 'Search Editor';
  • Assigned this role to the an user in Azure AD;
  • Login succesfull with the current user but no role retrieved

In this case the 'SyncRoles' does't work at all because it doesn't retrieve any role. 


Does anyone know what I'm doing wrong? See the screenshot for more information. 


Thanks in advance.


Regards,

Jorick

EmptyRole.png

Rank: #388

Jorick van Rijs wrote:

Hi,

I try to retrieve the role of a specific user aswell but the role remains empty in the request.

Let me specify it: 

  • Created a role in Azure AD called: 'Search Editor';
  • Assigned this role to the an user in Azure AD;
  • Login succesfull with the current user but no role retrieved

In this case the 'SyncRoles' does't work at all because it doesn't retrieve any role. 


Does anyone know what I'm doing wrong? See the screenshot for more information. 


Thanks in advance.


Regards,

Jorick

 Hi,

Long back I used the same. I followed a different approach. I used to get the list of user under a group from AD. That group I created in outsystems user module and assigned role to the group. Now I assigned the user inside the group by using a batch processing (timer). After successfully login I use the outsyatems roles instead of azure AD