14
Views
6
Comments
Solved
Error consuming SOAP webservice when using HTTP uri
Question

Hi,

We are consuming a SOAP webservice, using basic authentication. The uri definied in the WSDL is using HTTP protocol. No reference to HTTPS in the targetNamespace. OS11.

When we invoke the webservice, we're getting the error:

The provided URI scheme 'https' is invalid; expected 'http'.
Parameter name: via

The target service is configured to accept only HTTP requests.

Is there any way we can set the bindings to force secure mode to "none", to handle HTTP requests?

Thanks for the support.

Andre


Solution

Hi, 

Thanks for the support.

This issue was related with the WebService configuration (webservice consumed) that was configured to use a TranportBinding security to HTTPS, not allowing HTTP requests. 

This issue is now solved.

Thanks for the support.

André

Rank: #5595

Nuno André Araújo wrote:

Hi,

We are consuming a SOAP webservice, using basic authentication. The uri definied in the WSDL is using HTTP protocol. No reference to HTTPS in the targetNamespace. OS11.

When we invoke the webservice, we're getting the error:

The provided URI scheme 'https' is invalid; expected 'http'.
Parameter name: via

The target service is configured to accept only HTTP requests.

Is there any way we can set the bindings to force secure mode to "none", to handle HTTP requests?

Thanks for the support.

Andre


 

There are two places where you can check the option, but they are options referenced to EXPOSE, not CONSUME.

For check, in Service Center, go to Administration > Security. 


and for change the option, in Lifetime, go to Environments > Edit security settings


I hope I helped.

Thanks Giovane.

We're trying to consume a web service that we've already developed on our back-end system.

We've tested this webservice using the same WSDL with SoapUI with success.

We were consuming web services before the upgrade to the OS 11.

Thanks


Rank: #5595

Hi @Nuno, 

My suggest to you are open a Support Ticket for OutSystems Team evaluate your case, means be some configuration errors, but only with access detailed be possible to help more. 

Solution

Hi, 

Thanks for the support.

This issue was related with the WebService configuration (webservice consumed) that was configured to use a TranportBinding security to HTTPS, not allowing HTTP requests. 

This issue is now solved.

Thanks for the support.

André