Why Process Executing twice?

Hello,

I am using process to that execute server action 'that save excel data in table', but the process executing two times and hence data reflecting in data base twice.

Why Process Executing twice?

Please provide a solution for this.

Thanks In Advance.!!

Hi Ram,

Can you check what you set Process End 

It should be yes.

Regards

Rahul

Hi,

Can you please share oml, so we can check

I guess the Process is executing after creating an entity and also your calling it in Server action, so please check the Expose process entity(it should be No) and Launch on as well(it should be empty)

Rahul Sahu wrote:

Hi Ram,

Can you check what you set Process End 

It should be yes.

Regards

Rahul

 

 Yes I have Set it to Yes but still giving same result..!!

Hi Ram,

To find out a solution on this, we required further more detail on this..

1) How do you initiate the process, is it on create of any entity or is it initiating by using launch process action?

2) You must have written the logic into automatic activity, did you check the service center logs how much time that activity is taking.? Is it getting timed out? Since the process has default time out of 5 minutes, if it doesn't get complete within 5 minutes, it re-initiate again from the activity where it timed out.

Thanks,

Sachin



Thanks Rahul and sachin for your comments , I have actually made a mistake and now its working.

Hi RAM,


Can you share with us your solution? Maybe it can be useful for someone that made the same mistake in the future! :)


Thanks!


Best regards,

Ricardo  Pereira

Ricardo Pereira wrote:

Hi RAM,


Can you share with us your solution? Maybe it can be useful for someone that made the same mistake in the future! :)


Thanks!


Best regards,

Ricardo  Pereira

 Yep Agree, good to highlight the solution here.