13
Views
2
Comments
Authentication Error while using a wsdl file with Integration Studio
Question

Hello,

I have a two question related to Consuming a soap wsdl file in Outsystems.

1.  First I tried to consume the wsdl file using Consume SOAP Web Service , which it did but when I tried to publish the module I get the below error/s for all the methods I consumed. Any ideas as to why I get these errors?

2. I tried using the same wsdl file but this time using Integration Studio and making an extension and I was able to call the methods but I get the below error of invalid authentication. Is there a way I can solve this.

 

Rank: #82

Hi Baishai,
Would recommend you refer the logs from ServiceCenter for the same & then share the same with folks here...
Will be easy for folks here to answer.

https://success.outsystems.com/Documentation/11/Extensibility_and_Integration/SOAP/Troubleshoot_SOAP_Web_Services

Hope it helps,
Assif

Rank: #203

Hi Baishali,

In the first error seems like you maybe have a wrong data type in your structure output, your wsdl is updated?

Did you change manually the data types of structure?


In the second error the problem is with authentication...
If you are consuming it from an action in Integration studio, perhaps you have to passa the user and pass and manually create the Authentication Header...