Error saving in Configuration Tool and installing Service Center

Error saving in Configuration Tool and installing Service Center


I'm installing a new quality environment, using OS 5.1, in a new server, using Platform Server However I've made a backup/restore of a database used in the development environment, previously upgraded to 5.1 last month.

I read the Tech Note - MigratingBySQLClone and removed the hub* users after the restore. I configured the new environment, granted permission to the new users, tested the connection and everything was OK.

Afterwards I ran SCInstall.bat (after the updatedevicedb), and I got the exceptions in attachment. Meanwhile, I deleted the OSSYS_Server content (I forgot to do that before) and I was convinced that was the reason. I tried again the updatedevicedb and the SCInstall.bat., but the exception in attachment showed up once more.

I don't know if it's related, but I also have an error in the Configuration Tool, when saving the settings.

Does anyone have a clue of what could be going on?


Best Regards,
Ricardo Matos
Here is the Configuration Tool error that shows up when hitting the OK button. 
In spite of the error, the settings are saved.

After calling Outsystems support, the solution was simple: the Deployment Controller service was not working, hence it was impossible to install service center.
I restarted the service, but the problem continued. Actually the service was not starting at all. In Event Viewer I saw some Outsystems services related errors:

Deployment Service =>
Initialization error: System.Exception: Missing "IIS.RootDir" setting.
   at OutSystems.HubEdition.DeployService.Service.ValidateAndGetDirectorySetting(String setting)
   at OutSystems.HubEdition.DeployService.Service.ReallyStart()
   at OutSystems.HubEdition.DeployService.Service.StarterThread()

Deployment Controller Service => 
Initialization error: System.Exception: Missing "CompilerService.PublicationPath" setting.
   at #aQb.#FQb.#1Tb(String setting)
   at #aQb.#FQb.#VTb()
   at #aQb.#FQb.#WTb()

This happened because IIS was already installed in the server when I started the installation, but there was no 'IIS 6 Metabase compatibility' configured. This was the cause of both errors:
- Configuration Tool wrote to the local configuration file (somewhere in C:\Program Files\Outsystems\Platform Sever\...), but didn't write on the database. So I saw the correct DB settings in Configuration Tool, but IIS couldn't reach those settings through the DB.
- This caused the error when starting the Deployment services and the SCInstall.bat returned the error.

Hope this post can help future desesperate installers! :)

Best regards,
Ricardo Matos

Hi Ricardo,

Thanks for sharing. It will surely help others with the same problem.

Regards, and have a great weekend.

Paulo Tavares