Impact on Advance Query pluggin during Outsystems version upgrade.


I am using advance query pluggin to get date from external dB to outsystems 10.

This date value is being fetched in the int32 format. 

How can I get this in date and time format from external dB.


Note: Now recently I have upgraded my environment from outsystems 10 to outsystems 11.


Hi,

Is this kind of 

Example the date "2011-08-11" in format "yyyy-MM-dd" has an integer value of 734360 ?

Are you getting datetime in integer format? 

Can you give some more clarification?

I am getitng null values.

Michalle Sandya Amuthan wrote:


I am using advance query pluggin to get date from external dB to outsystems 10.

This date value is being fetched in the int32 format. 

How can I get this in date and time format from external dB.


Note: Now recently I have upgraded my environment from outsystems 10 to outsystems 11.


 Hello Michalle,

Though I didn't understand your issue exactly, I would like to suggest you have a look into this 2 thread:

https://www.outsystems.com/forums/discussion/35681/convert-number-to-date-inside-an-advanced-query/ 

https://www.outsystems.com/help/servicestudio/9.1/index.htm#t=Language_Reference%2FBuilt_in_Functions%2FData_Type_Conversion_Functions.htm%23Convert_to_Date


Regards,

Sanjay

 

Michalle Sandya Amuthan wrote:


I am using advance query pluggin to get date from external dB to outsystems 10.

This date value is being fetched in the int32 format. 

How can I get this in date and time format from external dB.


Note: Now recently I have upgraded my environment from outsystems 10 to outsystems 11.


 Hi,

How you are commenting external db? Have you created extension? If that, can u tell me or send a screenshot of the entity reflected in extension? 

Sorry for replying late.

 

Hi Michaelle!

If you can show us some prints or error logs as Sourav said I think we will understand a little better your problem to try to help you.


Just to make sure, when you say advanced query plugin you mean the default SQL element from OutSystems Service Studio? Or some forge component?

If you are using an extension to connect to this external database, have you tried to open it with Integration Studio and checked the mapped data type of your tables' attributes?

If using a SQL advanced query element, are you using the correct type in your return structure? 

I hope we can help you! 

Cheers and Regards,

RR :)