13
Views
7
Comments
Solved
How to turn off the device emulation for Silk Ui Web
Question

Hello guys, I am using Lisbon Theme for generating a web app, however I am not ble to turn this device emulation off? Any tips of how can I manage that?


Thank you

mvp_badge
MVP
Rank: #74
Solution

Hi Rodrigo,

You don't need to be sorry to ask questions :)

Let me walk you through it.

  • First, login to Service Center via https://<youroutsystemsenvironment>.outsystemscloud.com/servicecenter
  • Go to Factory >> Applications, search for Silk UI Web and open it

  • Next, click on the module Webpatterns


  • Then click on the tab Site Properties and look for the property DisableSimulationDeviceInDev (Just an FYI, the ForceSimulationDevice property is to enable device simulation on a Production environment, since it is disabled by default)

  • Click on that property and set the Effective Value to True. Then click Apply.

And that's it! The device simulation should be disabled now on your Development environment :)

Let me know if it worked for you.

Regards,

Nordin

mvp_badge
MVP
Rank: #90

Hi Rodrigo,

I'm not sure whether I understood it correctly or not.. Is it that you are referring about the browser device emulation??

If that is the case you can click the "Toggle device toolbar" option in the browser inspect element section (F12) as shown below..

If this is not what you intended, could you please share a bit more information about your use-case with us, so that we can help you better :)


Kind regards,

Benjith Sam

Rank: #51817


No, I am referring to such thing that appears on the bottom of the page...


Which will cause the page to be rendered like that, while the page is resized, if the Device Emulation is turned is turned on:

mvp_badge
MVP
Rank: #74

Hi Rodrigo,

Your question has been answered in this post.

The official documentation on this topic can be found here.

https://success.outsystems.com/Documentation/SILK_UI_Framework/05_Understanding_Responsive_and_Adaptive#Device_Simulation

Hope this helps!

Regards,

Nordin

mvp_badge
MVP
Rank: #74
Solution

Hi Rodrigo,

You don't need to be sorry to ask questions :)

Let me walk you through it.

  • First, login to Service Center via https://<youroutsystemsenvironment>.outsystemscloud.com/servicecenter
  • Go to Factory >> Applications, search for Silk UI Web and open it

  • Next, click on the module Webpatterns


  • Then click on the tab Site Properties and look for the property DisableSimulationDeviceInDev (Just an FYI, the ForceSimulationDevice property is to enable device simulation on a Production environment, since it is disabled by default)

  • Click on that property and set the Effective Value to True. Then click Apply.

And that's it! The device simulation should be disabled now on your Development environment :)

Let me know if it worked for you.

Regards,

Nordin

Rank: #51817

Yeah, it worked fine for me thanks a million

mvp_badge
MVP
Rank: #74

You’re welcome Rodrigo.

Enjoy the OutSystems platform!