15
Views
2
Comments
Since reinstalling service center server.api and server.identity are not accessible

Since I reinstalled servicecenter, server.api and server.identity are not accessible in environment health with 'one or more errors occurred'. This was not an issue before reinstalling servicecenter. I am able to access the health check jsons

In the error logs, the error HTTPS connection required keeps appearing where it did not before (and started immediately after reinstalling servicecenter). There is a valid certificate on the server and nothing has changed except for the service center being reinstalled. 

mvp_badge
MVP
Rank: #17

Hi Stephen,

Awaiting someone can help you with this on the forum, I suggest you create a support case to OutSystems too.

Regards,

Daniel

mvp_badge
MVP
Rank: #72

Hi Stephen,

First let me ask you what was the reason you needed to reinstall Service Center?

Second, what Platform Server version are you on?

I remember I faced this issue once. If I'm not mistaken it was due to a bug that was fixed in a later Platform Server version (can't remember which one).

As a workaround that worked for me at the time, you could try the following.

  • Turn off the Force HTTPS for exposed integrations in Web Applications setting and apply the changes

  • Reinstall Service Center
  • Check if the Server.API and Server.Identity endpoints can be reached again via Environment Health page
  • Turn back on the Force HTTPS for exposed integrations in Web Applications setting and apply the changes

Let me know if it worked for you.

Regards,

Nordin