22
Views
13
Comments
Solved
Binded data to assign widget but in browser "No items to show..",table has record
Application Type
Traditional Web

Hello everyone,

i have problem at one point in web application, table having proper records. i used aggregate to read records from database. after that data binds to assign widget. No error there and successfully compile and run. Yet in browser message shows that "No items to show.."

Guide me ... Thank you

mvp_badge
MVP
Rank: #71
Solution

Hi Pranav,

From your screenshots I noticed the SOAP call is called ‘RetriveAllClient’ so I presume it returns a List.

Therefore, instead of an Assign, you should use ListAppendAll action from System to append all the items from the SOAP call (Source List) to your Local Variable of type List (Destination List).

Make sure your Local List is bound to the Table Records.

Hope this helps.

Regards,

Nordin

Hi! 

Please can see if in Service Studio  you can see records in aggregate?

That massage is not an error, is the normal message when the aggregate don't return any record. It can be because the entity is empty, or the records don't meet the conditions you put in the filters. 

Hope this helps

Graça

In traditional web the screens do not refresh automatic. Are you refreshing the table when your aggregate is refreshed? 

Sorry if this is do not make sense but I don't know your application. 


Rank: #492

Hi Pranav,

It would be great if you can share a sample oml replicate the same behaviour , so that we can better understand what is exactly going wrong.

Thanks !!

Hi! 

The action in image 1 is called from the "Preparation"?

Where have you used the refresh? 

mvp_badge
MVP
Rank: #71
Solution

Hi Pranav,

From your screenshots I noticed the SOAP call is called ‘RetriveAllClient’ so I presume it returns a List.

Therefore, instead of an Assign, you should use ListAppendAll action from System to append all the items from the SOAP call (Source List) to your Local Variable of type List (Destination List).

Make sure your Local List is bound to the Table Records.

Hope this helps.

Regards,

Nordin

Hello Pranav,


Can you also post property of assign widget. As Nordin suggested, you can use ListAppendAll , but most importantly your Local variable should be of List of same type as you are getting data. I can see a warning in assign, so there may be problem with assign.


Sanjay