10
Views
5
Comments
Solved
InvalidRequest: The requested MABS version (6.1) is obsolete or does not exist.
Question


Hi

I keep having this error when trying to generate an app for iOS.

Error:


In iOS on 13/11/2020 at 15:21:05 - Failed to request mobile app generation for T1 Operations (iOS) - InvalidRequest: The requested MABS version (6.1) is obsolete or does not exist.


How to fix this?


Thanks

Rank: #94
Solution

Hello again Faris,

In order to change your MABS version, you need to go to Service Center -> Factory -> Applications -> Enter in your application -> Distribute Tab.

Then you'll find something like this:


Here you can find the configurations for both iOS and Android builds. If you click in Configure, you'll see your configurations (the same that you have in Service Studio) and you will be able to change your MABS version:


If you pick "Always use the latest version available" option, the platform will use the latest version by default and you don't need to change anything when a new MABS version release comes out. If you select "Specific version", the platform will always use that selected version and you may need to change that same configuration in the future (for example, if that version becomes obsolete or unavailable).


Hope that this helps you!


Kind regards,

Rui Barradas

Rank: #94

Hello Faris,

Hope you are doing well!


Can you try to generate with the latest MABS Version (6.3)?

Other versions are considered as deprecated and Version 6.1 doesn't appear to me:


I believe version 6.1 doesn't exist anymore, that's why you are getting that error. Please try to generate with the latest version and it should work as expected.

You can see this documentation about available and deprecated MABS versions: https://success.outsystems.com/Support/Release_Notes/Mobile_Apps_Build_Service_Versions


Hope that this helps you!


Kind regards,

Rui Barradas

Rank: #94
Solution

Hello again Faris,

In order to change your MABS version, you need to go to Service Center -> Factory -> Applications -> Enter in your application -> Distribute Tab.

Then you'll find something like this:


Here you can find the configurations for both iOS and Android builds. If you click in Configure, you'll see your configurations (the same that you have in Service Studio) and you will be able to change your MABS version:


If you pick "Always use the latest version available" option, the platform will use the latest version by default and you don't need to change anything when a new MABS version release comes out. If you select "Specific version", the platform will always use that selected version and you may need to change that same configuration in the future (for example, if that version becomes obsolete or unavailable).


Hope that this helps you!


Kind regards,

Rui Barradas