Logging in with SAML taking user to the OutSystems Users application.
Application Type
Reactive

Hi,

I am using SAML-based authentication and it's working fine but sometimes after I enter my credentials it's taking me to the Outsystems user's application instead of going to the home page. Not sure what's going on here.

Thank you for your time.

I am not sure about the exact scenario where this is happening to you, but from my experience I have had this happen when a Login flow is triggered after the user is already logged in. For example:

  1. Open MyApp in two browser tabs
  2. Go to first tab, click Login in one of them, and then login successfully
  3. Go to the second tab and click on Login again (it takes you to the OutSystems Users module)

Something that helped me avoid this problem is adding a check in your login flows (e.g. Interface > Common > UserInfo > ClientLogin) so that if the user is already logged in, it doesn't redirect them to the SSO URL and instead takes them to some other Screen in your application. For example, add something like the following before the User_GetUnifiedLoginUrl Action (GetUserId() <> NullIdentifier() Effectively checks if the user is already logged in):

There is a chance this is not enough to solve the problem completely but it should be a step in the right direction.

Hi  Francisco Calderón,

Thank you for your reply. I followed your suggestion but I am still getting the same thing.

Thank you for your time.

Hi,

Did we solve this? I am having the same problem, I followed the doucmentation https://success.outsystems.com/Documentation/11/Managing_the_Applications_Lifecycle/Secure_the_Applications/Configure_App_Authentication and enabled SAML in users application now its not redirecting back to my application page.

Regards.

Hi Prasad,

I am not sure which environment version you are using but this bug was fixed in platform release 11.10.1(you can find this information in the release notes). I was able to fix this issue by upgrading the environment.

Thanks.

I am currently in 11.12.1 (Build 30548) but still facing it, did they reintroduce this bug?

Regards.

Hi @Nannu / @Prasad Rao ,

You must declare redirect URL in "Configure Authentication" Page. URL : https://<Your Environment>/Users/ConfigureAuthentication.aspx

The default redirect URL for SAML is "https://<Your Environment>/Users",

OS Platform admin can configure this.

I had same issue in the past.. after configuring redirect URL, the issue got resolved.

Thanks,

Aadhavan S

Hi,

what I can see is it works for traditional web but not for reactive web. Are you suggesting that we should build our own redirect page?

Regards

Hi,

SSO is working now even in reactive, it just needed sometime for some reason.

Regards.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.