17
Views
7
Comments
Solved
link in the email and Setting Hostname (On-Premise)
Application Type
Traditional Web

Hello,

I would like to Click the link from an email to redirect to a web application but I am facing a problem when I click the link because " : " disappear from the URL  that makes I can't reach to the web application.


For example: 

This picture has shown the screen of an email from Service Studio.


This picture has shown the screen After I clicked the link from an email.


This picture has shown how we setting the hostname in Service Center.



Could you please suggest how to fix this problem?


Best regards, 

Technical Team Spheresoft

Solution

Hi Nordin,

We have already applied them by publishing solutions but it still doesn't work.

But now, we found the solutions to solve this problem by changing the hostname in Service Center to be the domain name instead of the old IP address. Thank you for your advice.

Regards,
Technical Team Spheresoft

Rank: #64

Hi there,


Can you try getting the URL with GetEntryURL (action from HTTPRequestHandler)? Something like this:


Regards,
João

Hi João,


I have already tried this solution too, it still doesn't work.


Regards,

Technical Team Spheresoft

mvp_badge
MVP
Rank: #72

Hi,

Also try removing the "https://" from the environment hostname in Service Center.

You should set the Security Settings in Lifetime to force HTTPS for all screens.

Regards,

Nordin

Hi Nordin,

I tried following your suggestion to remove "https://" from hostname and config in a lifetime but I got the result as below

1. The Link in Email is disabled: This Link, I Set Destination by the following picture

Result of 1.


2. The Link in Email disappear : This Link, I set the destination to Screen by the following picture

Result of 2.


 Regards,
Technical Team Spheresoft




mvp_badge
MVP
Rank: #72

Hi,

Have you applied the configurations by publishing a solution containing all modules? Editing the Security Settings means you are changing a Compile-time Setting which requires a republish of your modules for the change to take effect.

Additionally, changing the Hostname property inside Service Center means you have changed a Runtime Setting. For this you can click the Save and Apply Settings to the Factory button in order for the change to take effect.


You can read more about applying configurations in Service Center here.

Regards,

Nordin

Solution

Hi Nordin,

We have already applied them by publishing solutions but it still doesn't work.

But now, we found the solutions to solve this problem by changing the hostname in Service Center to be the domain name instead of the old IP address. Thank you for your advice.

Regards,
Technical Team Spheresoft

mvp_badge
MVP
Rank: #72