[Charting Services] Discussion

[Charting Services] Discussion

Forge Component
Published on 2010-02-17 by Susete Henriques
2 votes
Published on 2010-02-17 by Susete Henriques

In your online presentation the charting grid works fine, but in the downloaded example ( report

#Transactions by Year and Client Gender and Account) you get a black line separating the year (2006 - the first line), I mean

year     cliente gender     account
2006           F                      checking
----------------------------------------------      the line   (not ok  - still 2006   should not be here)
2006          F                      savings
              -----------------------------------      (ok)
                 M                        ...
------- ------------------------------------    (ok)
2007          etc

Is this some kind of bug in the sample  (is there a fix)?
Appreciated your help on this.


Thanks you for the post.

ok, found the problem and fixed it.

in the Report_Edit  web screen   go to the javascript

int the function    function grouprows(id) {


for( i=table.rows.length-1; i>1; i--) {

to this

for( i=table.rows.length-1; i>0; i--) {

(i>1    changes to i>0)

there you go. Small change, problem solved



Fernando Duarte

I'm using an extension to query a mysql database and get the records into a charting services chart.
The select orders the records by month number, however i want to display the month names, so after the select, the extension transforms the month numbers into month names, and that's ok.
The records therefore are properly ordered by month number when they are sent to the charting services chart, (the records of course already have the  month name instead of month number). The problem is that, in the chart, the months appear ordered alphabeticaly (and that's not ok).

The months appear  April,August, etc....   (ordered alphabeticaly)   not ok.

My question is :: Does the graph reorder the records again ??  I thought the graph showed the records as they came from the record list .

Thanks in advance

Fernando Duarte
Hi Fernando,

I believe the results will always be ordered alphabetically. So you can either format those dates to something that can be sorted alphabetically (e.g. YYYY-MM) or you'll need to modify the component.

Tiago Simões 
Hi, Tiago

The problem is that something like "YYYY-MM"  still orders the bad way alphabetically, i mean:
So it's not really a workaround (at least the way i see it)
So, really there are only a couple choices
go by month number or as you suggested alter the component.
Concerning the last option, you mean altering the .js or the .swf ?


Fernando Duarte
Hi Fernando,

Concerning the last option you would not need to change the swf only the eSpace logic.

As for formatting the dates you would need trailing 0's in the months. The AccountSample actually does this (http://compsqa.outsystems.net/AccountSample/Report_Edit.aspx select Month in categories).

It uses the LEFT(CONVERT(CHAR(10),{AccountTransaction}.[Date],111),7) SQL expression to format the dates that way.

Tiago Simões

Hi Tiago,

Yes, i just saw that, and you are right, thanks for your answer.
I was just converting that to mysql,  and it works just fine.
Thanks again for your helpful answer.

Best Regards
Fernando Duarte
Hi again,
I've been working with charting services again, and recently i noticed that in the graph when a category doesn0t have a series (in the select)  the series appears in the graph with a Zero.  This clutters the graph and induces in error.

I looked at the chartingservices espace and jumped into the ReportGetChartDataXML action. It turns out that the series value is always wirtten. So to take care of the problem i putted an if in the action to rprevent non existing seris from gertting a Zero.

Could you also implement this change in the future?


fernando Duarte
sorry, dumb question.

The way the graph is constructed (xml series association with categories) doesn't allow taking the zeros out.

it would be nice thou, but not possible.

Ok, thanks

Fernando Duarte

I am very excited about Charting Services. I have downloaded the eSpace and the AccountSample. The account sample works fine. I am trying to integrate Charting Services into my eSpace Application. I have been able to create charts by passing ChartXML but have been unable to get Charts to work using queiries. I have imported the account sample web flows into my application. When I try to preview a report I get two loading messages on the screen but no results. From the same screen I am able to successfully download to excel.

I am at a bit of a loss as to how to debug my problem.

Any help or suggestions would be greatly appreciated.


Well good news here. I took another approach to this problem. I copied the AccountSample eSpace and then merged my application with the new AccountSample eSpace and the charts all work fine. Not sure why the initial approach of including Charting Services and Account sample references did not work.


I am so close to making this work in my application. Can you please see if you can tell what is wrong with this chart (in the attachment) having too many categories? It looks like it is in including the grand total and values are shifted to the right for each category.

Just upgraded to Agile Platform 6.0. I can not get Charting Services to deploy in 6.0.

Is this being addressed?

Thank you
Hi Gregg,

What do you mean with "you can't get it to deploy in 6.0"? What exactly are you experiencing? What's the error you're getting?

I am not aware of such a behavior, so I would assume that you would do best to report it from Service Studio or Service Center, when the problem occurs.

Let us know more details, so our support team can look into it.


Paulo Tavares
Hi Paulo,
I did send feedback when the publishing error occured to support including the eSpace. It basically goes all the way through the 1-click publish and then gets an error saying it could not ping the server. Other eSpaces have compiled and deployed on my machine using the 6.0 platform without any problems.
I really hope this can be resolved as I have several months worth of development time into this.
As a fall back how would I roll back to 5.1.x - I have tried but can not find a way to get Service Center back to a 5.x release.
Thank you for your response.
Hi there,

I'm using the eSpace ChartingReports in a project. I have already used it in a previous project without any problem (Platform Server 5.1). I think that now my problem is related with the platform version (Platform Server 7.0) that I'm using. I think that the eSpace JavaScript below is breaking the buttons with the submit method. The piece of Javascript that I think that is doing this is:

responseText= responseText.replace(/<script[^>]*>((?!\/script)[\s\S])*?OsPage((?!\/script)[\s\S])*?<\/script>/,'')
//responseText= responseText.replace(/<script[^>]*>((?!\/script)[\s\S])*?doPostBack((?!\/script)[\s\S])*?<\/script>/,'')
responseText= responseText.replace(/<!-- Begin ECT Block -->.*<!-- End ECT Block -->/,'')
    responseText= responseText.replace(/<form[^>]*>/,'')
    responseText= responseText.replace(/<\/form[^>]*>/,'')
    responseText= responseText.replace(/<input[^>]*name=\"__VIEWSTATE\"[^>]*>/,'')
    responseText= responseText.replace(/<input[^>]*name=\"__OSVSTATE\"[^>]*>/,'')

Any ideas why this could happen? I have already put a comment in the line that I think that is doing the break/error in the page.


Best Reggards,
Nuno Mendes
It's seems that it stays without the default button defined and goes into that strange page that we all know, when that happens.
Any ideas, why?

Best Reggards,
Nuno Mendes