Problem in the 1-Click Publish

Problem in the 1-Click Publish

  
Hi everyone.

While trying to publish my eSpace to the localhost, i've got the following message in the 2nd step of the publish (Compiling):

System.Runtime.Remoting.RemotingException: 3 arguments were passed to 'OutSystems.HubEdition.ICompiler::GetCompilerResult'. 5 arguments were expected by this method.

Server stack trace:
   at System.Runtime.Remoting.Messaging.Message.CoerceArgs(MethodBase mb, Object[] args, ParameterInfo[] pi)
   at System.Runtime.Remoting.Messaging.Message.CoerceArgs(IMethodMessage m, ParameterInfo[] pi)
   at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at OutSystems.HubEdition.ICompiler.GetCompilerResult(String componentName, String testAreaName, Int32 timeout)
   at OutSystems.NssOMLProcessor.CssOMLProcessor.MssGetCompilerResult(String ssComponentName, Int32 ssTimeout, String ssPTA, Boolean& ssCompleted, RLHEMessageRecordList& ssMessages, Int32& ssErrorCount, String& ssErrorText)


The eSpace uploads without problem, but it doesn't publish. The same message appears while trying to publish trough the Service Center. Any ideas?

Thanks in advance

Carlos Almeida
Hi Carlos,

The only reason I could think of by looking at the stack is some sort of incompatibility of versions between the Service Studio, Service Center, and/or the Platform Server version.

My immediate recommendation would be for you to upgrade the Platform Server to the latest version in your major (so, either the latest 4.2.x or 5.x), and service Studio as well.

What versions are you using, by the way?

Regards,

Paulo Tavares
Hi Carlos,

Try to use the "recover" functionality doing this:
Open your eSpace by command line with the recover option. Something like...

C:\Program Files\Outsystems\Service Studio 5.0> ServiceStudio.exe -recover "c:\YoureSpaceLocation\YourEspaceName.oml" 

In some cases, even when ServiceStudio TruChange doesnt complain about the eSpace, that procedure works and solves some possible inconsitency. 

Best Regards,
Rafael Pereira

Hey guys, thanks for the fast answers.

Gonna try the recover solution, then try to update the versions to the most recent possible (Using 5.1 btw)
Nice! Keep us in touch. 
Ok, tried both solutions, none worked :(

Tried to recover before updating, updating the platform (publishing the eSpace and recovering), updating the service studio (publishing the eSpace and recovering) and nothing worked :( same error...

Any info I may offer to help solve this problem? Or should I take this directly to support? :S

Thanks anyway for the help guys :)
Hi Carlos,

When you upgraded the Platform version, did you:

1 - Open the Configuration Tool, and press the "Create/Upgrade Database" button?
2 - Then clicked the "Ok" button,
3 - And finally executed SCInstall, as described in the manual upgrade checklist document?

I would expect that doing the SCInstall step would fix your problem, because it does look like the Service Center web services are not updated and in sync with the compiler services ones...

If you have already done it, well, then yes, for sure you need to take this to the support department, because it does sound like a bug. However, that should not be the case, I hope.

Let us know if this helps.

Regards,

Paulo Tavares
actualy, i did not :p

i'm on it :p
Well, tried that option, still doesn't work...

should i just uninstall everything and install again or contact the support?
Hi Carlos,

No, do not unistall everything.

Do contact our support department, since they're better equipped to troubleshoot the situation, and hopefully help you!

If you manage to fix it, please post the solution here when you get it, since I'm afraid more people might stumble into similar problems in the future.

Regards, and sorry for not being able to help you much more.

Paulo Tavares

I've sent word of it up to support.

Thanks anyways for all the readyness to help :D
Hello there,

do you have the same problem when clicking the Run button in Service Studio?
I'm not sure if it is the same kind of error, but some days ago I've got something very similar. I solved it by desabling the eSpace in Service Center and change the Application Name (Service Studio>eSpace Properties) and Publishing it again.

I'm really not sure if it could help, but give it a try.

Cheers,
-- --
Ricardo Saraiva
Hi,

i just upgraded to following versions and had same issues that "7 aruguments were expected by this method" etc.,

Upgraded to->>
  Service Studio - 5.1.1.19
  PlatformServer - 5.1.1.19
  IntegrationStudio - 5.1.1.7

To resolve, I followed three steps from Paulo Tavares post. The issues were resolved and eSpace published successfully.

>> from Paulo Tavares
When you upgraded the Platform version, did you:

1 - Open the Configuration Tool, and press the "Create/Upgrade Database" button?
2 - Then clicked the "Ok" button,
3 - And finally executed SCInstall, as described in the manual upgrade checklist document?

thanks Paulo..

~Sam