Error accessing ServiceCenter

Error accessing ServiceCenter

  
Hi, i am trying to acces servicecenter gives me this error

Environment Fault: Unable to contact OutSystems Deployment Controller Service. Please make sure this service is running on 'localhost' to obtain licensing information.

I have the services enable and started

regards,
Luis
Hi Luís,

Is anything being logged in the server's Event Viewer? Any errors, or any messages?

Is it a laptop, or a desktop server environment? Have you changed - or disabled - any networking hardware?

Regards,

Paulo Tavares
Hi,

Its a laptop, is my localhost.
in the event logger, says this

Initialization error: System.Exception: Missing "CompilerService.PublicationPath" setting.
   em #7Mc.#BNc.#TQc(String setting)
   em #7Mc.#BNc.#NQc()
   em #7Mc.#BNc.#OQc()
Retrying in 30 seconds

Ocorreu um erro fatal ao tentar aceder à chave privada da credencial Servidor de SSL. O código de erro devolvido pelo módulo criptográfico é 0x8009030d. O estado de erro interno é 10001.
Hi Luis.

Did you per chance upgrade the Platform Server by hand, and did not follow the upgrande checklist?

If you did, try:

1 - Opening the Configuration Tool;
2 - Clicking the "Ok" button;

It looks like some sort of server problem. Is it a new installation, or what did you do to your computer recently that caused this change?

Regards,

Paulo Tavares
It worked, but when said it would restart the process,  not restarted. I had to start them manually.
Hi Luis,

Thanks for the reply.

When you say it worked, but you had to restart the process manually, does it mean that you no longer have the original problem, and that the only issue you had was that the process didn't start automatically, is that it? If that's the case, I'm glad that it sorted out your problem.

What opening the configuration tool and clicking "Ok" does is to create and save all Agile Platform configurations. Since configurations sometimes change between upgrades, that should always be done in an upgrade. If you want to learn more, read our installation checklist document - it covers everything you need when installing the Agile Platform.

Another thing that is also usually recommended is to execute "SCInstall" in the command line, under the the Agile Platform's folder.

The services might not have restarted, since they were probably not running. If they are not running, I don't think the Configuration Tool starts them on its own, since it doesn't want to run services that you don't want running.

Best regards, and good work.

Paulo Tavares
I already starded and stoped, and restart the services, and that give me the same error, but after the tip, iI was able to successfully login in servicecenter, and did a backup of the import stuff and reinstall the server. And now its working well.

Regards,
Luis
I am facing a similar issue. We tried restarting the Outsystems server using 'service outsystems start' command but it is throwing [WARNING] for four of the services and running "service Outsystems status'"command after that is showing the services in STOPPED status
Hi swapnil,

Check your /opt/outsystems/platform/log/ folder.
It will contain logs for each of the services and you can check the end of it for errors.
See the DeploymentController.log file, it will have details why the service if failing to start.

When you run the configuration tool does it give any errors?

Regards,
João Rosado
 Hi,
I checked the DeploymentController.log file and its giving the following error:015-05-25 15:19:31,554 ERROR [outsystems.hubedition.servercommon.utils.v] (main) Exception in thread "main"
2015-05-25 15:19:31,561 ERROR [outsystems.hubedition.servercommon.utils.v] (main) java.lang.ExceptionInInitializerError:
2015-05-25 15:19:31,561 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at java.io.File.deleteOnExit(File.java:939)
2015-05-25 15:19:31,561 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at oracle.ucp.util.UniqueIdentifier.initJvmInstanceId(UniqueIdentifier.java:80)
2015-05-25 15:19:31,561 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at oracle.ucp.util.UniqueIdentifier.<clinit>(UniqueIdentifier.java:34)
2015-05-25 15:19:31,561 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at oracle.ucp.common.UniversalConnectionPoolBase.<init>(UniversalConnectionPoolBase.java:290)
2015-05-25 15:19:31,561 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at oracle.ucp.common.UniversalConnectionPoolImpl.<init>(UniversalConnectionPoolImpl.java:83)
2015-05-25 15:19:31,561 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at oracle.ucp.jdbc.JDBCConnectionPool.<init>(JDBCConnectionPool.java:36)
2015-05-25 15:19:31,561 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at oracle.ucp.jdbc.oracle.OracleJDBCConnectionPool.<init>(OracleJDBCConnectionPool.java:116)
2015-05-25 15:19:31,561 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at oracle.ucp.jdbc.oracle.OracleConnectionConnectionPool.<init>(OracleConnectionConnectionPool.java:35)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at oracle.ucp.jdbc.PoolDataSourceImpl.createPoolWithDefaultProperties(PoolDataSourceImpl.java:307)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at oracle.ucp.jdbc.PoolDataSourceImpl.createUniversalConnectionPool(PoolDataSourceImpl.java:389)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at oracle.ucp.admin.UniversalConnectionPoolManagerBase.createConnectionPool(UniversalConnectionPoolManagerBase.java:566)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.runtimeservices.db.ojdbcpool.OJDBCPoolAux.initializeConnectionCache(Unknown Source)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.runtimeservices.db.ojdbcpool.OJDBCPoolAux.<init>(Unknown Source)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.runtimeservices.db.ojdbcpool.OJDBCPool.getConnection(Unknown Source)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.runtimeservices.db.ojdbcpool.OJDBCPool.connect(Unknown Source)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.runtimeplatform.db.RtDbHelper.getConnection(Unknown Source)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.runtimeplatform.DBConnectionManager.getConnection(Unknown Source)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.runtimeplatform.OracleConnectionManager.getConnection(Unknown Source)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.runtimeplatform.DBConnectionManager.getConnection(Unknown Source)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.runtimeplatform.DBConnectionManager.buildTransactionInfo(Unknown Source)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.runtimeplatform.OracleConnectionManager.addToPoolAndReserve(Unknown Source)
2015-05-25 15:19:31,562 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.runtimeplatform.OracleConnectionManager.getPrivateTransaction(Unknown Source)
2015-05-25 15:19:31,563 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.servercommon.utils.PlatformVersionUtils.$krb(Unknown Source)
2015-05-25 15:19:31,563 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.servercommon.utils.PlatformVersionUtils.validateServiceStartup(Unknown Source)
2015-05-25 15:19:31,563 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.servercommon.ServiceFunctions.onStart(Unknown Source)
2015-05-25 15:19:31,563 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.deploymentcontroller.Service.onStart(Unknown Source)
2015-05-25 15:19:31,563 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.servercommon.utils.ServiceBase.run(Unknown Source)
2015-05-25 15:19:31,563 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.deploymentcontroller.l.executeImpl(Unknown Source)
2015-05-25 15:19:31,563 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.deploymentcontroller.l.executeImpl(Unknown Source)
2015-05-25 15:19:31,563 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.util.delegates.Action$Action1.execute(Unknown Source)
2015-05-25 15:19:31,563 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.servercommon.ServiceFunctions.serviceMain(Unknown Source)
2015-05-25 15:19:31,563 ERROR [outsystems.hubedition.servercommon.utils.v] (main)     at outsystems.hubedition.deploymentcontroller.Service.main(Unknown Source)


There is no error while running configuration tool.


Thanks,
Swapnil





Hi Swapnil,

From the error it looks like the Oracle driver is failing to delete a temporary file it creates. This can be caused for example because of  strange security policies of your system (where a user does not have permission to delete temporary files)

If you don't have those type of customized settings in your linux instalation I would recommend you to open a ticket with OutSystems Support in order to troubleshoot the issue quickly.

Regards,
João Rosado