Trouble with debug

Trouble with debug

I am having trouble debuging my espace. I upload and run the espace just fine. When I add a breakpoint and enter debug mode the problems start. I hit run and get the message that it is ready to debug. At this point everything works fine. I can modify my espace. I can navigate around my site. When I get to a breakpoint things stop working. Service Studio locks up. My web browser shows the "loading" message and never pulls up the page. If I wait long enough I get this message:
Connection timed out while contacting 'localhost'. Check your network connection and if the problem persists increase the 'Short operations Timeout' value in Preferances.

At this point I can't connect to localhost. Service Studio is locked up and I need to kill it with task manager.

I've shut down my firewall to make sure it wasn't in the way. No change in behaviour.

Windows 7 64 bit
Hi Brandt,

Please, take in consideration two possible approachs to troubleshoot your issue:

1) Check if you dont have any "infinite" cycle on that flow
2) If you have a Anti-Virus / Firewall software running on your workstation, try to disable for test purpose. Some firewall/anti-virus clients may cause a kind of lock or interruption on ServiceStudio's debug proccess.

Keep us in touch! 

Best Regards,
Rafael Pereira
I shut down antivirus and firewall, and still get the same problem. Also, the not have any cycles in that loop, and I've tried on other loops.
Hi Brandt,

I am sorry to hear that you weren't able to fix your problem with Rafael's suggestions.

I suggest you submit this issue to our support department - it can be done directly through Service Studio, attaching the eSpace as well - because there might be either some technical difficulty that they can better help you troubleshoot, or you may have just stumbled upon a bug!

Let us know if - and how - you manage to get it to work, afterwards.


Paulo Tavares
Hi all...

I'm facing exactly the same problem than Brandt, and I tried exactly the same things than him with no results. I tried also with the versions and


Hi Emanuel, and welcome to our community forums.

In order to help us troubleshoot your scenario, could you do the following, and provide us with the results?

1.       Delete directory <pathToOutSystems>/PlatformServer/Share/<espaceToDebug>.
2.       Publish <espaceToDebug> using Service Studio 5.1
3.       On the browser access to http://<yourServer>/<espaceToDebug>/ ping.aspx and provide us the result.
4.       On the browser access to http://<yourServer>/<espaceToDebug>/<yourUser>/ping.aspx and provide us the result;
5.       Press run on Service Studio.

Also, when you try to debug the eSpace, could you check in Service Center if there are any errors or warnings being logged?

Finally, what's your system configuration?

Regards, and thanks.

Paulo Tavares
Hi Paulo... thanks!!
Thank you also for the help you're providing.

Well, I'm new in Outsystems, so probably I'm doing something wrong!

I can't access to the ping.aspx page (http://localhost/HRMSystem/ping.aspx), as you said in point 3, because it not exists:

In Service Center, there are no errors or warning being reported.

My system configuration is: Windows 7 Home Premium 64 bits, and Outsystems


Emanuel Falcão
Hi Emanuel,

No need to thank, after all we're all here to help - and you're probably not doing anything wrong, either, don't worry :)

The error you're getting is somewhat weird. Try publishing the application again using 1CP, and then accessing the ping.aspx . Does it return the same message? Can you access the application normally?


Paulo Tavares

I done it wrong: It's not ping.aspx, but _ping.aspx :D with an underscore !! Now shows this message: "OutSystems Platform Server is running", in both cases!!

I can access the aplication normally. Only fails in debug mode. The trouble is the same than Brandt. I've tried also to extend the timeout to 100 s with no results.


Hi Emanuel,

So you tried all 5 steps, and it still didn't work? Did steps 3 and 4 return the same result?

If that's the case, it must be a bug, and I would suggest reporting it to our support department, at , since this is becoming a more common scenario than what we would hope for.

Let us know about steps 3 and 4, and if you manage to fix it.


Paulo Tavares

EDIT: Also, do let them know that you already did these steps, and that the results were positive. :)
I was wondering whether anyone found a solution to this problem. I am having the exact same problem -- on a Vista machine -- basically, everything but the debugger seems to work fine -- every time I try and use the debugger, I get a "timeout" accessing localhost -- extending the time in preference doesn't help.

We have noticed the debugger goes down the drain when IIS is in integrated mode.
IIS should be in classic mode
Thanks for the response and the suggestion -- I checked but the OutSystems application pool in  IIS is already in Classic mode.
Hi Jack, and welcome to our community forums.

I've forwarded this to our support department, since they are better equipped to troubleshoot such situations.

Have you tried disabling firewalls and antivirus software, and seeing if it works?


Paulo Tavares
if you get timeouts on localhost, it might be the case that the platform-server cannot access localhost. (nameresolving issues)

At our company, sysadmins had decided to remove the localhost from IIS, so you cannot access websites with localhost.

Thanks for the response -- there is no firewall and all of the McAfee services are disabled, Vista Machine.

Either I am doing something worng (cockpit error) or there is some (obscure) configuration problem.

The debugger starts (it shows as paused) and it appears to be trying to get values from the platform server when it hangs -- thevariable names are there but the variaable values don't show in the debugger's tabs.

Also, I can select the platform server from the file menu and it seems to login fine, so I would think that the Service Studio thinks it can communicate with the Platform Server.

Very strange.

Hi Jack,

Were you able to overcome this problem?

With best regards,
Renato Gonçalves