14
Views
3
Comments
Solved
[InAppBrowser Plugin] When Version 2.4.0 for inappbrowser plugin will be available?
Forge component by OutSystems R&D
11
Published on 09 Dec 2020
Application Type
Mobile

Currently. when installing the latest stable version which is 2.3.0 of inappbrowser plugin getting  error while generating IOS build (screenshot for the error is attached).We are kind of stuck with this issue.Please let us know when will get the new plugin.Thanks!

ScreenShot20201228at11.38.20PM.png

Rank: #94
Solution

Hello Sushree,

Hope you're doing well.

As you can see, that error is beeing generated because there is an incompatibility between the plugin version and the MABS version that you are using.

The latest stable version (2.3.0) of InAppBrowser Plugin corresponds indeed to the plugin version 3.1.0-OS3:


May I ask you which MABS version are you using?

Most likely, you're using MABS version 7.0 and the latest version of InAppBrowser Plugin is not compactible with this new version of MABS. OutSystems will probably release a new version for this plugin very soon that is compactible with MABS 7.0 :)


Meanwhile, I suggest that you change your MABS version to its previous one (version 6.3) and you should be able to generate your app successfully.

In order to do that, please go to Service Center -> Applications -> Your app -> Tab Distribute. Click in Configure (for the platform that you pretend, iOS or Android) and then you can change your MABS version (for that application).

Instead of selecting Always use the latest version available option, please select Specific version option:



After that, you just need to click in Save and Generate and it will automatically generate your build.

I just tried for a new app (using this plugin) for Android and it was successfully generated using version 6.3:

For MABS version 7.0, I had the same error as you did:


I didn't try for iOS, but I believe that it will result in the same output :)


Hope that this helps you!


Kind regards,

Rui Barradas

Rank: #14656

Thanks lowering down MABS version worked.Thanks for the help

Rank: #323

Hi,
Just want to add, I've experienced that scenario before as well.

OS Support told me before to use the stable version first and just wait for the beta to be the stabilize before you can use it as more of the features in beta might not be compatible with some libraries otherwise, you could also expedite the fix (by calling in OS Support if all else fails) into the beta if the current stable version produces a blockage/no workaround when you are trying to generate the mobile installer.

Cheers,

JohnGB