12
Views
3
Comments
Solved
Dropdown list on mobile not showing values but showing "[object Object]"
Question

Hi,

For some reason, now the Dropdown list on mobile is not showing values but showing "[object Object]". Is this a known issue? These are using static entities but I assume it will happen for any entity. Please help, thanks:

Rank: #67
Solution

Hi Fadi,


Which widget is the Select you are using?

If you are using a Forge component, you might want to drop this question on the component page to grab the attention of their creators so you can get a quicker response.


Alternatively, you can always use the platform built-in and supported Dropdown or the Dropdown Search and Dropdown Tags available under OutSystemsUI.


Regards,
João

mvp_badge
MVP
Rank: #75
Solution

Hi Fadi,

Referring to the shared screenshot, I think you are using an external/customized Dropdown widget for this implementation. I tried with the default OutSytems Dropdown widget and for sure it's working as expected.

If possible, could you please let us know or share the customized Dropdown widget code i.e. Sample .oml file or the reference to the respective used forge component for us to help you better.


Kind regards,

Benjith Sam 

Rank: #67
Solution

Hi Fadi,


Which widget is the Select you are using?

If you are using a Forge component, you might want to drop this question on the component page to grab the attention of their creators so you can get a quicker response.


Alternatively, you can always use the platform built-in and supported Dropdown or the Dropdown Search and Dropdown Tags available under OutSystemsUI.


Regards,
João

Rank: #754

Thank you both, it looks like it was a different widget and when I used the Outsystems UI dropdown it solved it! Thank you.