16
Views
8
Comments
Solved
Invalid Expression After 'If'
Application Type
Traditional Web
Service Studio Version
11.10.4 (Build 36716)

Hi

When i use an 'If'-statement in my Preparation, i get an 'Invalid Expression -error' on an action that is defined after the if? Is there a way to avoid this?



Thanks in advance.


Huub Keulartz

mvp_badge
MVP
Rank: #76
Solution

You're welcome, Huub.

Just a request for you to mark the post as a solution that helped you, It really motivates the forum contributors :)

Gald to help you :)


Best regards,

Benjith Sam

Rank: #18359
Solution

Hi Benjith Sam 

I noticed allready that it wasnt avaliable.

Your remark  put me on the right track and i created the variable.

Problem solved!

Thanks!!!


Huub


Rank: #70

Hi Huub,


From the error, my best guess would be that you are referencing PopulateYearList on the first False branch, when you only instantiate the PopulateYearList after the first True branch.


Regards,
João

Rank: #387

Hi,

Validate the condition in the IF to see if it references something from the PopulateYearList.

or Try to delete some connectors and connect again.

Regards, 

Fabrice

Rank: #295

Hi Huub,

Could you please double click on that error and show us where you are exactly getting error? I think the reference of PopulateYearList in expression is not correct.

Thanks :)

mvp_badge
MVP
Rank: #76

Hi Hubb,

In addition to the previous suggestions, I just want to include one more point i.e. make sure that the element (i.e Output/Input/local variable value), which you are referring to the IF node expression editor must be available under the Scope tree as shown below

Hope this helps you!


Kind regards,

Benjith Sam