18
Views
3
Comments
Migrate p10 to P11 menu does not work
Application Type
Traditional Web

hi there

we have just migrated from P10 (java) to P11 (dot net). Unfortunately, some of the menus we created does not work in P11. What is likely the cause?

best regards and thanks 

Hello,

It really hard to tell what might be the problem without knowing more details. Why does in do not work? Is it a weird behavior or does it just throw a JS error?

Did you check the the side effects and breaking changes of Outsystems 11? If not I'd recommend starting from there. Maybe you can identify your problem there.

Additionally, are you using OutSystems UI (or any other component for that matter)? The problem might be there and you might have to upgrade those components as well.

IG

Rank: #397

Hi IBOX,

As Ivo said its hard to tell you how to fix that, but according my experience of migrating 10 to 11 says you should check that you are using Outsystems UI .Make sure that you are not using any silk ui component within OutsystemsUI. One of the point. and you can go through:

link:https://success.outsystems.com/Support/Archive/11/OutSystems_Platform_side_effects_and_breaking_changes


Regards,

Amreen


Rank: #283

Hi IBOX,


The possibility is on p10 is still using SILK and p11 using OutsystemsUI.

We also doing migration from p10 to p11, here is what we do :

1. Download (upgrade) SILK to OutsystemsUI (mobile reactive and web)

2. Open Service studio and change dependency from SILK to OutsystemsUI

3. Fix any error message (usually different parameters on the OutsystemsUI)


Thanks