52
Views
7
Comments
[Case Management framework] SetupCaseManagementApplication action missing
Forge component by OutSystems R&D
6
Published on 01 Mar 2021

Hi, I'm trying to follow case management documentation to create a case management app. Using the latest version of OutSystems 11 on partner cloud and already have installed the Case Management Framework from Forge.

In the very first step of adding case management dependencies, SetupCaseManagementApplication action from the CaseConfigurations_API producer is missing. In fact, whole setup folder is missing from CaseConfigurations_API. Seems like the instructions are not aligned with what's actually in API.

Would you please suggest?

SetupCaseConfig.png

Rank: #2505

Hi Khurram,

SetupCaseManagementApplication is available in CaseConfigurations_API.

Check out Outracker forge sample as well in module OutTracker_CS.


Alexandre Yip
Rank: #698

Hi Alexandre, on our end it's not there. When I install OutTracker in my environment, I get lots of missing dependencies including SetupCaseManagementApplication action in CaseConfigurations_API. See the attached from OutTracker dependencies. Refreshing dependencies in OutTracker shows number of errors. So I was not able to run OutTracker in my environment.

I have tried in my personal environment and it's same.

CaseConfigurationsAPIOutTracker.png

Rank: #2505

Hi Khurram,

It's seems that there are some dependencies incompatibilities. 

What I would suggest is you to use a clean personal and try it there.  

In my case I did install it in a clean environment and I'm able to check the sample and do my tests in the framework.




Rank: #698

The dependencies start appearing once created a test app and published using Workflow Builder in our partner cloud environment. I don't know why is that but tried to clean environment, reinstalled Case Management Core multiple times but dependencies were not appearing.

Now OutTracker app is not showing missing dependencies as well.

Rank: #6278

Hi @Khurram Rathor,
I just had the same issue a few hours ago.
I tried to uninstall it and install it again, it simply worked. It might be due some update done by the team behind the component.

Best Regards,

Tomás Dionísio

Staff
Rank: #1339

Hi Khurram,

The new Setup folder with the SetupCaseManagementApplication action was introduced in the latest version of the CMf (v1.1.1) , launched on the 14 December 2020.

When Workflow Builder publishes an application to any environment, it automatically installs the latest version of the CMf if that version has not yet been installed. This may be the reason why it started working all of a sudden.

I would like to ask if you were installing version v1.1.1 of the CMf, and if you were choosing the 1-Click Publish button. 

If you choose the Upload option, the CMf is only saved to the Platform Server and is not ready to run. You should choose the 1-Click Publish which not only saves it but publishes it as the latest version.



If you have any other issues or feedback, please feel free to reach out to us.

Best Regards,

Paulo Sebastião

Rank: #698

Thanks Paulo, perhaps I didn't press the 1-Click Publish button after uploading. Publishing from workflow builder got it fixed.