Integration Studio 5.1 does not launch

Integration Studio 5.1 does not launch

Hi I am new to the product and am having an issue.

When I launch the Integration Studio 5.1 it starts the program and I can see it in the process task list as running, but it does not display anything and just sits in the process list with no CPU and the memory usage not changing.

Note that the Service Studio runs without any issues.

I am running on a Windows XP SP3 system
Hi Bruce, and welcome to our community forums!

I am sad to hear that you're experiencing such a difficulty.

What is the version of Integration Studio you are running? If you aren't able to boot it up, there's a Version.txt file on the installation folder with the version number. That could help us better determine what's going on.

Another thing or two I may suggest are:

- If you have just installed the platform, and have not rebooted the computer, then please reboot it and open it again. That happened to me once, and it turned out to be Windows not registering some of the components until it restarted.

- If that doesn't work out well, I'll suggest downloading the latest standalone version of Integration Studio, installing, and seeing if the behavior still occurs.

I am sorry for the lack of ideas, but I hope this helps you somehow. Let us know how it all turns out.


Paulo Tavares
Hi Paulo,

Thanks for your suggestions.

I rebooted and tried to run the integration server 5.1 and same behaviour can see the process but getting no CPU time and memory usage is static.

I downloaded the latest standalone version you linked.

I Rebooted and tried to run the Integration Server 5.1, with the same results.

Version.txt (build 22991: tags/v5_1_0_24 @ 2010-11-16 16:22:21)

Hi Bruce,

I reported this issue to our support department, but they weren't aware of similar occurrences.

One thing I'm going to suggest is for you to run the Integration Studio, and check in the Windows Event Viewer (under Control Panel > Administrative Tools, if I recall correctly) if there's any warning or error being logged.

Let me know of your findings.


Paulo Tavares
Hi Paulo,

I brought up Process Explorer, and the windows event view and took a screen shot of all of them and the screen shot is attached.

There are no errors or warnings being reported in the Event viewer.

Thanks for your help.
Hi Paulo,

When I killed the Integration Server process I received the following message in the Event viewer.

The Software Protection service has completed licensing status check.

Application Id=59a52881-a989-479d-af46-f275c6370663

Licensing Status=

1: 191301d3-a579-428c-b0c7-d7988500f9e3, 1, 0 [(0 [0xC004F014, 0, 0], [(?)(?)(?)(?)(?)(?)])(1 )(2 )]

2: 6f327760-8c5c-417c-9b61-836a98287e0c, 1, 1 [(0 [0x00000000, 1, 0], [(?)(?)( 1 0x00000000 30 0 msft:rm/algorithm/volume/1.0 0x00000000 254840)(?)(?)(?)])(1 )(2 )]

3: fdf3ecb9-b56f-43b2-a9b8-1b48b6bae1a7, 1, 0 [(0 [0xC004F014, 0, 0], [(?)(?)(?)(?)(?)(?)])(1 )(2 )] 

Looks like it is looping on trying to find the licensing information. Does Integration Server require a license beyond the community version default install?


Sorry I think my last posting is misleading... it appears to be a MS Office license verification message and nothing to do with the Integration Server.

Thanks Bruce Kirk
Hi Bruce,

That's weird... Have you tried running it since? So, killing all Integration Studio processes, and then launching it again?

Integration Studio does not do any check whatsoever for any licensing module... Actually, that error seems to be related to MS Office 2010, though I'm finding it hard to establish a connection between IS and MS Office, at least at first sight...

Does this help somehow?


Paulo Tavares
Hi Paulo,

One other issue that maybe related or maybe not.....

For the Service Center I am getting the following error in the Windows Event. - About the Message Queuing has not been installed. I do not know if this is related or not.

Error sending log: System.InvalidOperationException: Message Queuing has not been installed on this computer.

at System.Messaging.Interop.SafeNativeMethods.MQPathNameToFormatName(String pathName, StringBuilder formatName, Int32& count)

at System.Messaging.MessageQueue.ResolveFormatNameFromQueuePath(String queuePath, Boolean throwException)

at System.Messaging.MessageQueue.get_FormatName()

at System.Messaging.MessageQueue.SendInternal(Object obj, MessageQueueTransaction internalTransaction, MessageQueueTransactionType transactionType)

at System.Messaging.MessageQueue.Send(Object obj, String label, MessageQueueTransaction transaction, MessageQueueTransactionType transactionType)

at System.Messaging.MessageQueue.Send(Object obj, String label)

at OutSystems.HubEdition.RuntimePlatform.Log.LoggerAsynchronous.GetMessageQueue(LogType logType)

at OutSystems.HubEdition.RuntimePlatform.Log.LoggerAsynchronous.Log(Object log, LogType logType, MessagePriority priority)

Hi Bruce,

Wow, that sure looks like a lot of stuff going on in your installation. I am going to forward all of this information to our support department, since they are definitely better equipped to troubleshoot and deal with the situation.

Let us know if you manage to solve it, and how.


Paulo Tavares
Hi Bruce,

As I mentioned, I forwarded this to our support team. However, from the look of it, their initial suggestion was for you to go to our download page at

and download the just-released new version of the platform, which includes some fixes that may solve your problems.

I apologize for the back and forth, but it's the best we can try to do on such short notice.

Do let us know how it goes.


Paulo Tavares