input file inside a table records

input file inside a table records

Hello all,

I have a Table Records of audits. For each audit I want to insert some files that is extra info for that Audit. In my Table Record I have added a column where I inserted an input filename. However the input file name widget inside the table record does not capture any information regarding the file I choose.

Any idea I can achieve this?

Thanks in advance and keep up the good work.
Hi Pedro, and thanks for your first post here in the Network - that's what we're here for!

I would like to understand better what you're trying to accomplish, so that could better understand what may be going on.

You have a table with several rows, and you have a column with input filenames, one per row, is that it? And then you have a button to submit the information to the server? If so, is the button's method "Submit"?

If that's not the problem, would you have a small eSpace that replicates the situation, so we can look into it - or, at least, a screenshot?

Regards, and good work.

Paulo Tavares

Olá Paulo,

thanks for your reply.
I attached a screenshot of what I have so far.

It is exactly what you said and I have the button to submit the information to the server.

As you can see I have a Tab inside the column so I can choose whether I want to display all the files of the audit or add a new one.
The only problem is that it seems the information of the file is not beeing submitted, I have debugged the program and all the fields from the input filename widget are null. If I place the input filename widget outside the table records it works like it is expected to work.

If you could give me a hand here I would much appreciate it.

Thanks once more.


I would suggest it being some problem in the widget-variable mapping... What variable are you mapping it to - especially since you have a lot of input filenames there?

Another suggestion to troubleshoot it: have you tried taking the input filename to outside the Tabs, but keeping it inside the table, and seeing if it runs?


Paulo Tavares

I changed the widget outside the tabs and still didnt work.

What you mean with the  widget-variable mapping?


Hi Pedro,

Have you tried this solution?:

Rafael Pereira
Hello Rafael,

Thank you for your link.

Apparently it works!

Thanks everyone.
Happy to Help You!