After pressing Delete in DATAGRID records are not deleted

After marking records an a datagrid to be deleted, and press button delete the following message is shown:
'Data updated Successfully.'

But the records are not deleted.

Strange thing is that it works fine for me but when another user tries the same thing, the above situation occurs. In my siutation when everything works fine, the message is not shown but a refresh of the grid is in place

Thanks Tom,

The Authentication is the problem. The Not_registered exception is raised.
Now I have to found out why!

Kind regards.
Cees

Must be something with session cookie settings but they are all the same.

Some debugging learned that a cookie nr2Users is fetched. But this one is always present so why it isn't always fetched is not clear to me.
It's kinda black box so help is appreciated.

Anyone an idea?

mvp_badge
MVP

Hi Cees,

Can you share some images of your delete stream, or your .OML for analysis?

Regards.

These are the images of the delete stream.
Hope this helps, thanks in advance


I did some digging again.


I't seems the URL is correctly specified in the server action all the times.

But the consecutive API (as specified in the URL) is not alwausexecuted.

Still I have no idea why?

Hi Cees van Oosten,

First you do one thing you can take a grid button is 

Actions\SendSelectedRowsButton

then set HTTP method to "Delete" in property. I have attached the screenshot as well please look at once and let me know.

I hope it will works.


thanks 

Yogesh satpute


Delete.png

Champion

Hi Cees,

if you can debug into your exposed API, then you can get more information.

And also did you added Authentication to your API? If so,  You should check it.

Kind Regards.



Thanks Tom,

The Authentication is the problem. The Not_registered exception is raised.
Now I have to found out why!

Kind regards.
Cees

Must be something with session cookie settings but they are all the same.

Some debugging learned that a cookie nr2Users is fetched. But this one is always present so why it isn't always fetched is not clear to me.
It's kinda black box so help is appreciated.

Anyone an idea?

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.