21
Views
5
Comments
PDF generating without text.
Application Type
Traditional Web
Platform Version
11.10.2.26915

Hello,

We have a problem in our On Premises environment, the PDF is being generating without text.

The images, tables, … appears but the text do not.

When doing a test on command line, we obtain some warnings:

Warning: Received createRequest signal on a disposed ResourceObject's NetworkAccessManager. This might be an indication of an iframe taking too long to load.

Error: Failed to load about:blank, with network status code 301 and http status code 0 - Protocol "about" is unknown


Can help us in finding the source of this problem?

Thanks for any help.

Regards

Miguel Anselmo

Champion
Rank: #99

Hi Miguel,

Sorry, but are you using some forge component to do that (like HTML2PDF our UltimatePDF) or is in your own code?

The webscreen that you are trying to convert to PDF, is with anonymous role checked? (already saw some problems that are solved with that "trick")


Best regards,

Ricardo M Pereira

Rank: #1922

Hi Ricardo,

we are using HTML2PDF  .

The page have anonymous role checked.

 

Regards

Miguel Anselmo

Rank: #1660

Hi,

 If you use HTML2PDF, you need to configure it, follow the link: 

https://wkhtmltopdf.org/ 

In this link you will find what is behind this component (HTML2PDF), documentation and the .exe needed to configure it. To configure, acess the component's eSpace on the Admin/Configurate page.

 


Rank: #1922
Hi,

we have already done that.

Regards

Miguel Anselmo

Champion
Rank: #270

Hi,

If you can replicate this problem on small demo apps, please share that oml so we can help to check that.

Thanks