language switcher workst only one time

Hi,


When I follow the steps to create the language switcher, it works only one time. If you want to switch the language a second time, the text in the body is not translated. If I call GetCurrentLocale, I see that the locale is changed.

I put an example oml in attachment.


Regards


Kevin Desmet


TestTranslate.oml

mvp_badge
MVP
Solution

Hi Kevin,


For Reactive, you can take a look at the Multilanguage Selector component.

It includes a demo and documentation on how to use.


Regards,
João

mvp_badge
MVP

Hi Kevin,

See this component:

https://www.outsystems.com/forge/component-overview/2463/language-selection

it was very useful to see how it works.

Hope this helps.

Regards.

Hi Agno,


I forgot to mention that I have this problem in a Reactive application and the new language component in the studio.

The component you suggest is for traditional web.


Regards

mvp_badge
MVP
Solution

Hi Kevin,


For Reactive, you can take a look at the Multilanguage Selector component.

It includes a demo and documentation on how to use.


Regards,
João

Champion

Hi,

We have encountered this same problem.
We know we can instead use the forge components available.

But we want to make you aware that this item being marked as "solved" is perhaps not justified.
Using the forge component for multilingual reactive is a workaround for the user, but not a solution  for the functionality being fixed.

The technical preview feature with multilingual reactive is still having the problem to date - 15.04.2021: 

Switching the locale between Norwegian and English (in our case) works once, but not a second time with the same description as the poster has given in our environment.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.