55
Views
6
Comments
[OutSystems UI Web] JavaScript errors in browser console after opening sidebar multiple times
Forge component by OutSystems R&D
61
Published on 22 Feb 2021
Application Type
Traditional Web

Hi,

I am getting following error after open and close the sidebar multiple times:

Reproduceable on https://outsystemsui.outsystems.com/WebStyleGuidePreview/Sidebar.aspx

Browser: chrome Version 87.0.4280.141

Is it a known bug? Can you provide a fix for it?

Thanks & best regards,

Magnus

Staff
Rank: #321

Hi Magnus,

It seems like it, indeed.

I've added this to our backlog to be fixed in a future version, cheers.

Rank: #515

Hi Magnus,

After some digging, I have found that the problem is with the Accessibility and a dynamic content. 

I couldn't replicate the problem here. I create a screen with a sidebar and it worked fine without errors. But I didn't use dynamic contents.

Despite of that, as informed by Dinis, this is an known bug, so, if it is bothering you, I would recommend you to turn off the accessibility of the screen to see if it will stop. 

In order to do this, set EnableAccessiblityFeatures of LayoutTopMenu of the screen to false.

Hope it helps.

Best regards.

Rank: #25208

Hi Kadu,

thanks for your efforts, but how can I "set EnableAccessiblityFeatures of LayoutTopMenu of the screen to false"?

I am not able to find an option for this:

I did the following:

Best regards,

Magnus

Rank: #515

Hi Magnus, 

I 've just realized that EnableAccessibilityFeatures is only available in reactive apps. Sorry for the mistake.

From all these steps, the only one that a didn't do was to select the "Ajax Submit" from the Method drop down. I'm not able to test it now, but soon as I can, I will do it.

Best regards.

Rank: #515

Hi Magnus, 

I have tried again and now I could reproduce the error, but I didn't find any solution. The problem is that the DOM is not totally loaded when the JS executes. I have tried some approaches, but they didn't work with ajax. Sorry.

Hope they fix it as soon as possible. If you find something, please, post it here.

Best regards.

Rank: #25208

Hi Kadu,

thanks for testing it again.

Looking forward to the fix in the forge component.

Best regards,

Magnus