15
Views
13
Comments
Error: Cannot decrypt the content using iframe
Application Type
Traditional Web

I have a Outsystems application in imbedded using iframe to another website  which works great. However within the Outsystems application it has an external link which directs user to another Outsystems application page. Once that button is clicked I get the Cannot decrypt the content error message.

How do I set the 'SameSite'  setting to  'None'? 

From what I have seen online its a cookie security issue. I know there are a lot of questions regarding this issue but I am yet to see a solution or explanation on how to solve this issue. Any help would be appreciated. 



Rank: #541

Hi Yats,

Please, see the link bellow. Maybe it could help you.

https://www.outsystems.com/forums/discussion/34408/error-deserialising-viewstate-cannot-decrypt-the-content/

Best regards.

Rank: #27236

Thank you for the reply. The discussion in the link doesn't  actually produce a solution. Do you have any suggestions ?

Rank: #541

How much content do you want to share with the other application?

Rank: #27236

It's a external URL to another OS application that wont open in the Iframe

Rank: #541

Let me try to understand:

You have an Outsystems app inside an Iframe. This app wants to redirect to another page, but a problem is raised every time you try to do it?

Rank: #27236

Yes within the OS app theres a button that takes you to another OS application but I get an internal error 'Cannot decrypt the content' error.


Rank: #541

Have you tried to set the sandbox attribute of the iFrame tag?

<iframe sandbox="allow-same-origin ">

Rank: #27236
Rank: #27236

Yes but im not sure where or how to add the cookie or header

Rank: #56

Hi Yats,


You can add an iframe to your page dragging the HTML Element widget from your sidebar to your screen and setting the Tag as iframe.

Additionally, you can set up the attributes of this HTML element like the iframe URL with the attribute src, like in the example below:


I think you need to put the attribute allow with value encrypted-media to overcome this error like in my example below.


Hope it helps.


Kind Regards,
João

Rank: #27236

Hi,

Thank you for your response. 

My Outsystems application  is actually added to another website using iframe and I have external URLS linked to the Outsystems application. However when I try to access a link within the website from my Outsystems application, I get the above error message. 

I read it could be due to setCookie or AddCookie but doesnt seem to be working.


Thanks

Rank: #541

Hi Yats,

I have tried a lot, but I didn't find a way to overcome this issue.

If you encounter someway to fix it, please, share it with us.

Good luck.