[Data Grid Reactive] At the time of initial focus, the mode set in IME does not work
Forge component by Bruno Martinho
Application Type
Reactive
IME is working well when double-clicking. But At the time of initial focus, the mode set in IME does not work. 
I want to use keys(UpDownPage UpPage Down) to move and write now without double click 

Solution

Hello Ricardo Valim
 

thanks for your help.


the mode set in IME does work well by using JS

 "GridAPI.GridManager.GetActiveGrid().grid.imeEnabled = true"

Hello Liu, 

Are you using Data Grid Web am I right? This feature isn't available on Data Grid Reactive version (yet).

Using the samples we have here I could navigate using arrow keys and start writing(IME Enabled) without problems.

Could you please verify the version you have of Data Grid Web.

An animated gif may help us too.

Sorry for the inconvinience

Ricardo Valim 


hi Ricardo Valim  

I am using Data Grid Reactive. I am sorry for the lack of explanation. IME is enabled. But At the time of initial focus, the IEM options seem to be disabled.

now I use Japanese(Microsoft IME), and change the IME's option to katakana(not "A").   and then navigate using arrow keys to a new cell.  then try to enter katakana, but the first letter is English.


Hello Liu

IME for Data Grid Reactive isn't available yet... sorry!

We are working to provide new features, but I don't have a target release date for IME yet.

Kind regards,

Ricardo Valim


Solution

Hello Ricardo Valim
 

thanks for your help.


the mode set in IME does work well by using JS

 "GridAPI.GridManager.GetActiveGrid().grid.imeEnabled = true"

Hello Liu

Yes... is that way to turn on it, but I need to say we don't validate this feature yet.

Can you create an idea here? If the feature is upvoted we will for sure consider to open a better way to turn on IME.

Thank you

Ricardo Valim


Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.