20
Views
6
Comments
Naming parameter as identifier

Hi,

I am facing an issue while working with Service Studio. 

For some time when I input parameter name (while defining parameter on screen or action) related to identifier for example "UserId", Service Studio recognizes it as "User" data type instead of "User Identifier".  It's very problematic to me as each time I have to select proper identifier, so there is no acceleration from Service Studio. I know it didn't work like that in the past. Does anyone know what happened and how to solve this?

Regards,

Michal

Rank: #541

Hi Michal Witek,

Have you tried to use the Data Type Editor to change this behavior?


Rank: #127

Hi Michal,

I noticed the same change a while back.  Service Studio makes a first guess and then sticks with it.  

I guess it's a fine line for OS tool to choose how often and when to re-guess as names change.  In earlier version of Service Studio I sometimes had explicitly chosen the type from the dropdown to what I want it to be, only to see it changed when I changed the name.

I think maybe there should be an option on each variable to either re-guess with every name change or not, so as a developer I can allow or block this behaviour as needed.  So something like a flag on each variable called 'use name type accelerator', being true by default when adding a new variable.  As soon as I am happy with the type, I uncheck the flag to make sure future name changes don't mess up the type.

Dorine


Btw, if you give the right name at the moment of creating the variable (so giving it the right name directly in the tree view, not later in the property pane), it works as you would expect.

I guess a lot would be solved if they waited until the developer tabs out of the Name property to do the type accelerator.

Rank: #642

Hi @Kadu Borges ,

No, I haven't. Could you please advise how to use Data Type editor to change this behavior?

Rank: #340

Hi Michal, 

What @Kadu Borges is saying is that you can change the parameter type through the Data Type editor (same if you click twice on the data type attribute of the parameter). 

But this won't fix the behaviour you have. If every time you add a new parameter, after naming it to UserId it shows as User record instead User Identifier, something is wrong with your studio I'm guessing. 

Best Regards, 

Paulo Z

Rank: #642

Hi Paulo Z,

Thanks for your reply. That is exactly how I understand it works. I thought @Kadu Borges may have some solution to that but I believe that's not the case.

So what's wrong with my Service Studio? Should I do the upgrade? Right now I am using version 11.10.7 build 37468.

Thanks.

Michal

Rank: #340

Hi again Michal, 

I'm not saying that in fact there's something wrong with your studio, however, if this keeps happening, I think you should open a support case to check what is the issue.

I'm not able to reproduce it since every time I add a new parameter and name it as UserId, it is working as expected, putting the data type as User Identifier.

Please note that if you are changing an existing parameter, it doesn't always change to the expected type, but when adding a new one, it should guess as User Identifier indeed on the case you exposed. 

Best regards, 

Paulo Z