22
Views
9
Comments
[Firebase Mobile] Error installing Cordova plugin: cordova-plugin-firebase
Question
Forge component by David Sousa
23
Published on 23 Feb 2021
Application Type
Mobile

I was trying to achieve push notification feature in a native Android mobile app. For this I was using the Firebase approach.

Used this component from forge

Firebase mobile - https://www.outsystems.com/forge/component-overview/4991/firebase-mobile

Followed a video tutorial for this process present on outsystems Youtube channel
video link - https://youtu.be/ygbu3AITS4k

I am getting an error as followed
 Have you seen this error before and thoughts on how to resolve it?

In Android on 02-12-2021 at 13:54:23 - Error installing Cordova plugin: cordova-plugin-firebase': Error: ENOENT: no such file or directory, scandir '/var/lib/builder/builds/eea5e5b8-30a2-454f-98e8-23e5a3a0e149/source/platforms/android/assets/www/google-services.
Please let me know if u need any more inputs from my side to resolve the issue.


Thanks in advance

Hi Hogirala,

Quick question. Did you follow the configuration guide?

IG

Hi IG,

Yes I have followed it and I am sure I have configured the json files correctly too

Thnx for the reply :)
Hemanth

Rank: #330

Hi,

from the error it seems google-services.json is not found, have you uploaded it to resources folder and followed the configuration steps correctly??


Regards,

Swapnil

Hi Swapnil,

I am sure I have configured the json files correctly. But not sure where else I might have gone wrong

Thnx for the reply :)
Hemanth

Champion
Rank: #134

Hey Hogirala,

If you followed the configuration guide then it should be working. Maybe you did something wrong during the steps.

Can you please share your oml/oap and the app identifier you're using?


Thnx David

Will upload my oml file here

PushNotificationsSolutionsvPushNotification.osp

Champion
Rank: #134

If you had follow the configuration guide correctly, you'd have seen that the zip folder name has to be 'google-services'



Cheers

David

Rank: #22442

Hi,

I'm not sure, but I think if the app id is not right the same error will occur.

Confirm if you have the same value for the bundle_id/package name on the google-service.json and the app identifier on service studio. 


If they are not the same, it means that what you defined in the following image is probably not correct.

NOTE: if the app is available in 3 environments you need to create 3 google-service.json, 1 for each environment.


Regards

Hi
I rechecked for above error. I didnt come across any mistake of this kind

Thank you