Model is not defined (error in reactive app using the DropdownTags widget)
Application Type
Reactive
Service Studio Version
11.10.10 (Build 38781)
Platform Version
11.10.0 (Build 22910)

I have a reactive app on my personal environment, which is a back office to maintain recipe data where you can add an image, the recipe ingredients and tags. For the tags I use the DropdownTags widget.

The on change handler calls a service action which is referenced from a Core Service module called Recipe_CS.

The service action first deletes the assigned tags from a many-to-many entity where RecipeId = the recipe I'm editing. Secondly it inserts new records based on the DropdownTags CurrentList. This 2 step logic allows users to both add and delete tags and they get saved in Recipe_CS on every change, without needing to click any save button.

When I add a tag to a recipe, I get the following error message: 'Recipe_CSModel is not defined'

Thanks for helping me out !

--------

I'm adding service center error details below:

ReferenceError: Recipe_CSModel is not defined
    at https://wimdemaeyer.outsystemscloud.com/HouseHoldNinjaBackOffice/scripts/HouseHoldNinjaBackOffice.MainFlow.RecipeTags.mvc.js?eUEl4PVPUF_oO6rCd0xnVw:363:184
    at d (https://wimdemaeyer.outsystemscloud.com/HouseHoldNinjaBackOffice/scripts/OutSystems.js?5nDbdRKHkFGAjYmzYfZYrQ:2:12015)
    at f (https://wimdemaeyer.outsystemscloud.com/HouseHoldNinjaBackOffice/scripts/OutSystems.js?5nDbdRKHkFGAjYmzYfZYrQ:2:11761)
    at Object.m [as executeAsyncFlow] (https://wimdemaeyer.outsystemscloud.com/HouseHoldNinjaBackOffice/scripts/OutSystems.js?5nDbdRKHkFGAjYmzYfZYrQ:2:12545)
    at Controller._dropdownTagsOnChange$Action (https://wimdemaeyer.outsystemscloud.com/HouseHoldNinjaBackOffice/scripts/HouseHoldNinjaBackOffice.MainFlow.RecipeTags.mvc.js?eUEl4PVPUF_oO6rCd0xnVw:353:16)
    at https://wimdemaeyer.outsystemscloud.com/HouseHoldNinjaBackOffice/scripts/OutSystems.js?5nDbdRKHkFGAjYmzYfZYrQ:15:15578
    at d (https://wimdemaeyer.outsystemscloud.com/HouseHoldNinjaBackOffice/scripts/OutSystems.js?5nDbdRKHkFGAjYmzYfZYrQ:2:12015)
    at f (https://wimdemaeyer.outsystemscloud.com/HouseHoldNinjaBackOffice/scripts/OutSystems.js?5nDbdRKHkFGAjYmzYfZYrQ:2:11761)
    at Object.p [as tryCatchFinally] (https://wimdemaeyer.outsystemscloud.com/HouseHoldNinjaBackOffice/scripts/OutSystems.js?5nDbdRKHkFGAjYmzYfZYrQ:2:12264)
at Controller.t.safeExecuteClientAction (https://wimdemaeyer.outsystemscloud.com/HouseHoldNinjaBackOffice/scripts/OutSystems.js?5nDbdRKHkFGAjYmzYfZYrQ:15:15542)


mvp_badge
MVP

Hi Wim,

This shouldn't happen. I'd advise you to open a support ticket with OutSystems.

Hello @Wim Theo M De Maeyer 

I already face that issue. I don't know why but the issue occurred both in Webblocks and a Screen.

I solved it in the Webblocks by copying the screen actions, aggregates, and Forms, etc. to a new webblock, and replace the old webblock.

Hope this can helps.

Regards.

Gonçalo Almeida



i passed with the a similar problem that may helps you as following:

  • I've created a shared webblock, and its input parameter is a list of structure
  • when i call this consume this block by another module, i got the "ModuleNameModule is not defined" error

So, i fixed it by creating a wrapper structure inside the producer module that contains the list of struct attribute, now the produce block input parameter is that wrapper struct, and this fixed the problem. please have a look at the following screenshots.

This worked for me. Thanks for saving my day :)

This worked for me as well, thank you so muuchh!!!! 

Thanks! It worked

Do you have any Idea why this happened? how did you replicate the error?

Hi all,

This did not work for me. Instead I add to change a mapping from this:

to this:


Also, the list SelectedProfilesIdList was a List of Identifiers. Now it is this structure:


I am not sure if this is related or not, but it produces the same error in the title ("<Module Name>Model is not defined").

I hope this helps anyone! :)

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.