14
Views
4
Comments
Solved
[File Viewer Plugin] Update for MABS 7.0
Forge component by Experts
7
Published on 28 Aug 2020
Application Type
Mobile

When is an update planned for this component to be compatible with the new MABS 7.0 framework of OutSystems?

Currently our app generations fail due to this component when we use 7.0 so we are stuck on 6.3.

Kind regards,

Rank: #4088
Solution

Dear Dieter,

I can see there is a version of the file Plugin v3.0.1 which is under development by OutSystemsR&D since last 3 weeks. Did you try to use the under development version and check if the issue is getting resolved with that version?

Using the under development version will just be a temporary workaround so that your dev activities can proceed. Once the stable version is released, which I believe will be released very soon, you can import the the stable version.

best regards,

Shounak

Rank: #3680

Dear Shounak,

we currently keep our development on MABS 6.3, to stay with the stable version of the file plugin. Because our application is already in production and we want to only use stable versions of plugins in production.

Therefor we will leave it on MABS 6.3 till it's marked as stable, therefor this issue is resolved seeing that we know the cause and have a workaround.

Best regards,

Dieter

Rank: #4088

Dear Dieter,

Can you please verify in the plugin that is installed in your environment is using the below git URL?

"https://github.com/OutSystemsExperts/File-Viewer-Plugin.git#1.2.1"

We are using this plugin and are able to generate the apps successfully in MABS7.0

Regards,

Shounak

Rank: #3680

Dear Shounak, 

I have been in contact with support. The "File plugin" doesn't have a stable version yet that is compatible with MABS 7.0, that was the cause of this issue. 

My apologies for the confusion.

Kind regards,

Rank: #4088
Solution

Dear Dieter,

I can see there is a version of the file Plugin v3.0.1 which is under development by OutSystemsR&D since last 3 weeks. Did you try to use the under development version and check if the issue is getting resolved with that version?

Using the under development version will just be a temporary workaround so that your dev activities can proceed. Once the stable version is released, which I believe will be released very soon, you can import the the stable version.

best regards,

Shounak

Rank: #3680

Dear Shounak,

we currently keep our development on MABS 6.3, to stay with the stable version of the file plugin. Because our application is already in production and we want to only use stable versions of plugins in production.

Therefor we will leave it on MABS 6.3 till it's marked as stable, therefor this issue is resolved seeing that we know the cause and have a workaround.

Best regards,

Dieter