Bar Chart issue in Reactive Outsystems
Application Type
Reactive

I'm getting more values in Y-axis for the bar graph but if I add filter with limit values the counts are coming proper.

No label is shown on Y -axis for the shown bar.

Any idea guys?

Untitled.jpg

Solution

Hi Saksham,

Try setting the height of the chart - I faced the same problem and was able to correct it in this way.

Regards,,

Vera

Screenshot20210319085047.png

Thanks Vera!

Anyways I already raised a support ticket and got it resolved.

I appreciate your response.


Thank you very much once again!

Hi Saksham,

can you share the datapoint values (from debug maybe)

So this will either be a datapoint list, or the result of an aggregate or ???

And what filter are you talking about ?

Dorine

Kindly refer to the jpg file attached where no label is displayed on Y-axis for "Manufacturing".

I'm directly getting values from aggregates.

I was talking about the aggregate filters like if we filter the record only by Manufacturing label, the label is shown but if we have multiple labels to be shown like more than 40 labels then few Labels are not shown on the bar graph.

Regards,

Saksham Srivastava.

Ah, ok.  This might be related to limited space  available.

Is your chart in a div with a height, can you make it larger?  Maybe relate the hight to the number of rows in the query result ? 

Thanks for your response Dorine!

 I already tried to increase the size by making it larger in height and making it wider also but then also labels are not shown.


-Saksham Srivastava

Kindly find the sample OML file where we are facing this kind of issue.


-Saksham Srivastava

checkingUI.oml


Hi Saksham,

can you also give the checking_core oml, I can't test as it is, and I don't see really anything wrong so far.

checkingcore.oml

Anyone who faced this kind of issue and able to rectify this could let me know...


Thanks,

Saksham Srivastava

Solution

Hi Saksham,

Try setting the height of the chart - I faced the same problem and was able to correct it in this way.

Regards,,

Vera

Screenshot20210319085047.png

Thanks Vera!

Anyways I already raised a support ticket and got it resolved.

I appreciate your response.


Thank you very much once again!

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.