9
Views
4
Comments
Solved
Is there a need to upgrade schema when it matches the platform server version?
Question
Platform Version
11.10.2 (Build 25738)

I've recently upgraded my platform server to 11.10.2 (build 25738).

When I click on "Create/Upgrade Database" in the configuration tool, it tells me that upgrade is not necessary as the data model version matches the installed platform server version (11.10.2.25738).

But when I click on "Test Connection" to the database, it tells me that the schema should be upgraded to the latest version (v11.10.30.60000). There doesn't seem to be such a release for the platform server. 

Is there a need to upgrade the schema or not? If yes, how do I proceed with upgrading?

mvp_badge
MVP
Rank: #73
Solution

Hi c3d,

I have checked with OutSystems. They confirmed it is a bug they were already aware of and the fix for it is also ready. It will be released in an upcoming platform server version.

As for your concern, it is safe to ignore the message and continue with the configuration. If hitting the ‘Apply and Exit’ button does not raise any errors everything should be fine.

Hope this helps!

Regards,

Nordin

mvp_badge
MVP
Rank: #73

Hi c3d,

We have recently also upgraded our environment to platform server version 11.10.2 (build 25738) and I noticed this same behavior when clicking on 'Test Connection'. I think it is a bug.

Actually there is a newer release for the platform server which is currently on version 11.10.3.

In any case, you can just continue with the installation since your database schema already matches your installed platform server version (11.10.2). We did the same and everything went fine.

Hope this helps!

Regards,

Nordin

Rank: #13070

Thanks for the info, Nordin.

I was just concerned there was a mismatch and may cause issues downstream when we are updating again.

mvp_badge
MVP
Rank: #73
Solution

Hi c3d,

I have checked with OutSystems. They confirmed it is a bug they were already aware of and the fix for it is also ready. It will be released in an upcoming platform server version.

As for your concern, it is safe to ignore the message and continue with the configuration. If hitting the ‘Apply and Exit’ button does not raise any errors everything should be fine.

Hope this helps!

Regards,

Nordin

Rank: #13070

Great to know it's being fixed.

Thank you, Nordin!