Converting circular structure to JSON - OutystemReactView
Application Type
Reactive
Service Studio Version
11.10.13 (Build 39571)
Platform Version
11.10.1 (Build 23852)

I only have this issue on QA, DEV is working fine.

When trying to access a screen that has DropdownSearch widgets I get :

Converting circular structure to JSON
--> starting at object with constructor 'DropdownItemList'
    --- property 'propagationParent' closes the circle

TypeError: Converting circular structure to JSON
--> starting at object with constructor 'DropdownItemList'
--- property 'propagationParent' closes the circle
at JSON.stringify (<anonymous>)
at <server/app>/scripts/OutSystemsReactView.js?PahhasDl8gM1CQQgUGwLJw:6:28112
at Object.R [as trace] (<server/app>/scripts/OutSystems.js?rleJRa8AwQvOo3T_0ZhAMA:2:16771)
at View.t.componentWillUpdate (<server/app>/scripts/OutSystemsReactView.js?PahhasDl8gM1CQQgUGwLJw:6:28041)
at View.o (<server/app>/scripts/OutSystemsReactView.js?PahhasDl8gM1CQQgUGwLJw:9:12017)
at View.e.<computed> [as componentWillUpdate] (<server/app>/scripts/OutSystems.js?rleJRa8AwQvOo3T_0ZhAMA:13:11375)
at c._performComponentUpdate (<server/app>/scripts/OutSystemsReactView.js?PahhasDl8gM1CQQgUGwLJw:2:20696)
at c.updateComponent (<server/app>/scripts/OutSystemsReactView.js?PahhasDl8gM1CQQgUGwLJw:2:20077)
at c.receiveComponent <server/app>/scripts/OutSystemsReactView.js?PahhasDl8gM1CQQgUGwLJw:2:19362)
at Object.receiveComponent (<server/app>/scripts/OutSystemsReactView.js?PahhasDl8gM1CQQgUGwLJw:4:9368)


I already published a fullFactory solution with full compilation just to be sure.

I don't have any component updates showing in Service Studio.

UPDATE : I only have this issue in this specific app. 

Created a clean reactive app, with only 1 DropDownSearch and 1 DropDownTag , showing Users table, and it works.

Hi Nelson,

It looks more common error when I do google it, but to be frank I have never come across such an error before. 

Just to check, did you try creating the page again or try deleting the DropDownSearch and re-create it again.? Also, do you see any difference in data that is binding to the dropdown comparing with dev env.

Sachin

Hi guys,

I went through the same error, I was not able to find or had the time to understand the root cause of it, I imagine that should be related to updated references or some garbage inside the IIs VIDIR, nevertheless, what I did to sort it out was:

  1. Clone the eSpace where we had the dropdown search that was causing the error
  2. Rename the original eSpace to "<module name>_Old"
  3. Rename the cloned version to the original name, 

and voilá it worked, in the cloned eSpace we no longer had the issue.

Note: In our case, the eSpace was an End User module that was not producing for any other module, in the case of being a _CW module or another kind of module that is producing for other modules, you need to update the producers for the new module.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.