Disable log for service actions table: oslog_SrvAPI

Service actions are nice but they take to much database space.

Is there a way of disabling this logging or maybe make it take less space?

Running in the free cloud on the latest stable version.

mvp_badge
MVP

Hi Freek,

I’m not sure. Have you tried disabling Activity Logging in SC under the Operation tab in the Module detail screen? The description only mentions Screen, Extension and Integration events but maybe Service Actions are also included.

As for making sure the logging takes less space, you need to have Service Action Logging set to ‘Default’ and not to ‘Troubleshoot’ or ‘Full’.

Hope this helps.

Regards,

Nordin

Hi Nordin,

Thanks for your feedback, they where both on default.

The thing is I want less logging so I assume I should put it on troubleshoot less logging takes place only I get a warning:



mvp_badge
MVP

Hi Freek,

Setting it to 'Troubleshoot' will increase the logging level:

"By default OutSystems does not log details about errors, the headers or the payloads of requests to the Service Actions. The default logging detail level reduces the amount of information stored in the environment’s database but makes troubleshooting difficult; you need to increase the logging level to Troubleshoot or Full."

You can read more about this here:

Regards,

Nordin

So it's already less as possible, where using service actions as microservices and after large amount of requests the database is getting full. Thanks for your help.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.